If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Restore some command-line arguments when restarting for update

RESOLVED WONTFIX

Status

()

Toolkit
Startup and Profile System
--
minor
RESOLVED WONTFIX
10 years ago
a year ago

People

(Reporter: Fabio Correa, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-GB; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-GB; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7

It would be nice if the command line used to run the current instance of Firefox is used also to restart it after an update. It is mainly about restarting Firefox in the same language when updated.

Reproducible: Always

Steps to Reproduce:
1. firefox -UILocale es
2. Update some extensions
3. Allow Firefox to restart
Actual Results:  
The first instance is run in spanish, but the second instance is run in english.

Expected Results:  
The second instance to run also in spanish.

What the restart button does is to barely run the command "firefox", not "firefox -UILocale es"

Comment 1

10 years ago
I don't think this is exactly what we want: in particular if you opened Firefox with a URL the first time, we probably *don't* want to open that URL the second time, but rather let session-restore do its job.

You could possibly say that you want it to remember the locale setting for next time, but why don't you simply set the locale pref?
Component: Extension/Theme Manager → Startup and Profile System
QA Contact: extension.manager → startup

Comment 2

10 years ago
See also bug 391977, a similar bug about crash-reporter restart.  These should probably share code :)

Updated

10 years ago
Severity: trivial → minor
Summary: Use current command line to restart after update → Restore some command-line arguments when restarting for update
(Reporter)

Comment 3

10 years ago
(In reply to comment #1)
> You could possibly say that you want it to remember the locale setting for next
> time, but why don't you simply set the locale pref?

Hey Benjamin, it is a great suggestion. Thanks!!!
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
Duplicate of this bug: 675785

Updated

6 years ago
Blocks: 675787
No longer blocks: 675787
Blocks: 686320
Same is true for profile specified as a flag which is the easiest way of getting multiple launcher icons for Ubuntu. (Can raise as a separate bug if needed)
Blocks: 1008135
Benjamin, we are hitting this problem all the time for Marionette with the ability to print application update logs to the console after an initiated restart in Firefox, but on Windows only. Has there something been changed over the years that we got some command line options carried over for OS X and Linux but not for Windows?
Flags: needinfo?(benjamin)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

a year ago
Henrik, could you be specific about the flags you mean? Commandline flags are intentionally not preserved on restart because that's usually not what the user wants: e.g. "open a new tab" "open a URL" etc. Configuration should usually be carried in the environment, not the command line.
Flags: needinfo?(benjamin) → needinfo?(hskupin)
What we are interested in are the dump() statements, which application update might also do when flipping app.update.log to true. When I start Firefox with -(attach-)console it works fine until I restart Firefox eg. to apply an update. Once Firefox is running again we no longer see the dump() output in the console.

Hm, but even when I do not add this command line option, the dump output should end up on stderr at least given by https://developer.mozilla.org/en-US/docs/Web/API/Window/dump. But after a restart this doesn't work anymore.
Flags: needinfo?(hskupin)

Comment 9

a year ago
Can you file a bug about that specific case? I'm going to WONTFIX this one, because in the generic case we don't want to assume that flags are valid after a restart.

I don't remember the details about how processes attach to consoles or pipes, so we'll need to dig a bit.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
(In reply to Benjamin Smedberg [:bsmedberg] from comment #9)
> Can you file a bug about that specific case? I'm going to WONTFIX this one,
> because in the generic case we don't want to assume that flags are valid
> after a restart.

Thanks. I filed bug 1299601 for that.
You need to log in before you can comment on or make changes to this bug.