Account specific error message does not mention the account name

RESOLVED DUPLICATE of bug 309121

Status

Thunderbird
Account Manager
RESOLVED DUPLICATE of bug 309121
11 years ago
11 years ago

People

(Reporter: M. Leben, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: 2.0.0.6 (20070728)

I have multiple IMAP accounts in the same profile. A few of them have the same Server Name (localhost in my case, tunneling over ssh.) but they all have different ports.

When one of the ssh tunnels is down and I try to check mail on all accounts I get this error message with caption Alert: "Could not connect to mail server localhost; the connection was refused." without telling the name of the account that failed.

Reproducible: Always

Steps to Reproduce:
1. Create two IMAP accounts using Server Name "localhost" but with different port numbers.
2. Establish ssh tunnels to two IMAP servers. Verify that "Get All New Messages" work.
3. Disconnect one of the ssh tunnels.
4. "Get All New Messages".
Actual Results:  
Error message with caption Alert: "Could not connect to mail server localhost; the connection was refused.".

Expected Results:  
Error message with caption Alert: "Could not connect to mail server localhost on account <account name>; the connection was refused."
/me thinks this dupes bug #309121
(Reporter)

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 309121
You need to log in before you can comment on or make changes to this bug.