Closed Bug 399478 Opened 13 years ago Closed 12 years ago

Accessing the GMail Inbox page While Window-eyes is Running Crashes Firefox

Categories

(Core :: Disability Access APIs, defect, critical)

x86
Windows XP
defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla1.9beta2

People

(Reporter: tkeenan, Assigned: aaronlev)

References

()

Details

(Keywords: access, crash, regression)

Attachments

(1 file)

1. Launch Window-eyes
2. Open gmail.com and log in.

Window-eyes will load the resulting page into its buffer but immediately crash.  Here's the url to a rellevant crash report:
http://crash-stats.mozilla.com/report/index/c8ea64c5-7762-11dc-a2fb-001a4bd43ef6?date=2007-10-10-18

I'm working on a regression range, but initially this seems to go back quite a ways into the alpha cycle.

I notified GW Micro regarding this bug.  Maybe we can put our heads together and figure out what's happening.
Severity: major → critical
Flags: blocking1.9?
Keywords: crash, regression
08-14-09 works, 08-15-05 crashes.
I'm not sure if this is related to bug 390670 or not.  Testing immediately after the fix for bug 387347 fixed bug 390670 confirmed that it was fixed.  That testing was done on 08-12.  
Blocks: fox3access
Tim, does it still crash for you?
Comment on attachment 286317 [details] [diff] [review]
Missing null check on the line for the crash (from the crash report)


>+  nsIDocument *doc = content->GetDocument();
>+  NS_ENSURE_TRUE(doc, NS_ERROR_FAILURE);
>+

GetDocument() is deprecated, use GetCurrentDoc() instead. Would you like to add an assertion, is it ok there is no document for node?
I'll add an assertion, since I don't understand exactly when that would happen.
Attachment #286317 - Flags: review?(Evan.Yan) → review+
Attachment #286317 - Flags: approvalM9?
Attachment #286317 - Flags: approvalM9? → approvalM9+
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Verified fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.