[de-SM2] Unnecessary buttons "OK" "Abbrechen" in cookie dialog

VERIFIED FIXED

Status

Mozilla Localizations
de / German
--
trivial
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: Sven Grull, Assigned: Robert Kaiser)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9a9pre) Gecko/2007101301 SeaMonkey/2.0a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9a9pre) Gecko/2007101301 SeaMonkey/2.0a1pre

Unnecessary buttons "OK" "Abbrechen" in cookie dialog

Reproducible: Always
(Reporter)

Comment 1

10 years ago
Created attachment 284741 [details]
German cookie dialog
(Reporter)

Comment 2

10 years ago
Created attachment 284742 [details]
English cookie dialog
(Assignee)

Comment 3

10 years ago
In der Error-Konsole sollte es dazu einen Fehler geben, in dem dialog.xml und irgendwas wie _confirmButtons oder so vorkommt. Wahrscheinlich hängt das Problem damit zusammen, den Fehler hab ich gesehen, ich muss mir genau ansehen, wo er herkommt...
Assignee: nobody → kairo
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

10 years ago
Stimmt, in der Fehler-Konsole gibt es einen Fehler, der auftaucht, sobald der Cookie-Dialog aufgerufen wird.

JFTR:
Fehler: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://global/content/bindings/dialog.xml :: _configureButtons :: line 235"  data: no]
(Assignee)

Comment 5

10 years ago
Created attachment 284864 [details] [diff] [review]
fix dialog.properties

Der Fehler liegt in dialog.properties - mit diesem Patch sollten alle Dialoge wieder korrekt funktionieren.
Attachment #284864 - Flags: review?(a.topal)
(Assignee)

Updated

10 years ago
Duplicate of this bug: 401884

Comment 7

10 years ago
Looking at the en-US dialog.properties, no accesskeys at all might be the right thing to do.

I recall being puzzled about this before, and there was some argument that made it sound ok. I think it was that OK is RETURN, cancel is ESC and help would be F1 or something, not sure about disclosure.

I filed bug 401887 to get some input on that tracked in the en-US file.

Updated

10 years ago
Attachment #284864 - Flags: review?(a.topal) → review+

Updated

10 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 8

10 years ago
Checked in, I'll follow the other bug about further steps.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

10 years ago
-v 2007110509
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.