gmail chat windows cannot be reopened

RESOLVED DUPLICATE of bug 370096

Status

Camino Graveyard
General
RESOLVED DUPLICATE of bug 370096
10 years ago
10 years ago

People

(Reporter: Simon, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.6) Gecko/20070809 Camino/1.5.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.6) Gecko/20070809 Camino/1.5.1

When you have a chat with someone from within gmail and you pop-out the chat into a separate window then close that chat window, you cannot reopen a chat with that person. or at least if you can, it doesn't appear anywhere.

Reproducible: Always

Steps to Reproduce:
1. login to gmail
2. open a chat with someone
3. 'pop-out' the chat window into a separate window
4. close the chat window
5. try to initiate a chat with that person again
Actual Results:  
the chat window does not appear the second time round

Expected Results:  
the chat window is visible and usable as normal each time you reopen a chat with someone

Comment 1

10 years ago
Does this work in Firefox (or any other Gecko browser) or in Safari, OmniWeb, or Opera?

I suspect it doesn't and this is a bug in Gmail.

cl
(Reporter)

Comment 2

10 years ago
i just tested:
- firefox 2.0.0.7, it worked fine.
- opera 9.22, same issue occurred.
- safari 3, gmail does not offer chat in safari 3 (might do in safari 2, not sure)

it seems to be related to the fact that the chat is popped out into a separate window. I tried these two cases:

1. initiate a chat with someone, the chat spawns within gmail window. pop out the chat into a separate window. close the chat. re-initiate with the same person. and nothing happens (bug)

2. initiate a chat with someone, the chat spawns within gmail window. do NOT pop out the chat into a separate window. close the chat. re-initiate with the same person. chat spawns within gmail window again. no problems.


maybe gmail doesnt receive the window close event?
could be a gmail bug. 
i have sent this bug to them too.

Is this related to/dupe of bug 369265?
(Reporter)

Comment 4

10 years ago
it definitely seems this would be caused by the same issue, however the effect is different. 

sorry for the duplication! i'm new to this and i searched open bugs by mistake... 

Comment 5

10 years ago
Yep, this was the onbeforeunload issue, so it will be fixed in the next release.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 370096
You need to log in before you can comment on or make changes to this bug.