Add UI to restore Smart Bookmarks queries (reset browser.places.smartBookmarksVersion)

VERIFIED WONTFIX

Status

()

--
enhancement
VERIFIED WONTFIX
11 years ago
9 years ago

People

(Reporter: Aleksej, Unassigned)

Tracking

({user-doc-complete})

Trunk
user-doc-complete
Points:
---
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9a9pre) Gecko/2007101504 Minefield/3.0a9pre

The Places folder is a normal bookmarks folder, so it can be edited and deleted easily.
A user may decide that they don't need the folder, but later want it back.

How do they know they need to set “browser.places.createdDefaultQueries” to “false” and restart?


→ There should be a UI for doing that or some way of accessing the instructions easily.

Updated

11 years ago
Duplicate of this bug: 402743
(Reporter)

Updated

11 years ago
Depends on: 401753
(Reporter)

Updated

11 years ago
Summary: Add UI to create default queries (Places folder) to Places Organizer (browser.places.createdDefaultQueries) → Add UI to create default queries (Places or Smart Bookmarks folder) to Places Organizer (browser.places.createdDefaultQueries)
note, the pref has changed as has the name of the folder
Summary: Add UI to create default queries (Places or Smart Bookmarks folder) to Places Organizer (browser.places.createdDefaultQueries) → Add UI to create default queries ("Smart Bookmarks" folder) to Places Organizer (reset browser.places.createdSmartBookmarks)
But with an older profile, you'll still have *both* prefs...
> But with an older profile, you'll still have *both* prefs...

right, there is no code to clear the (now) unused pref.

note, if we did, and you toggled back between b1 and b2, we'd recreate the "Places" folder when you ran b1.


My profile state scares me at times. I'm glad we back things up.
(Reporter)

Updated

11 years ago
Flags: blocking-firefox3?
Not blocking, nice to have, maybe, but I don't think its altogether that useful when people can easily revert to older bookmarks if they need to.
Flags: blocking-firefox3? → blocking-firefox3-

Updated

11 years ago
Keywords: uiwanted

Updated

11 years ago
Duplicate of this bug: 415071

Updated

11 years ago
Flags: blocking-firefox3-
Beltzner, could you please re-set the blocking-firefox3- flag? It was accidentally removed by a CC member. It seems that we need a protection for final decisions. 
Flags: blocking-firefox3?
Re-added; though I'll admit it kinda sucks that you can lose these queries and never get 'em back.
Flags: wanted-firefox3+
Flags: blocking-firefox3?
Flags: blocking-firefox3-
actually queries are restored setting browser.places.smartBookmarksVersion to 0
Summary: Add UI to create default queries ("Smart Bookmarks" folder) to Places Organizer (reset browser.places.createdSmartBookmarks) → Add UI to create default queries ("Smart Bookmarks" folder) to Places Organizer (reset browser.places.smartBookmarksVersion)
Summary: Add UI to create default queries ("Smart Bookmarks" folder) to Places Organizer (reset browser.places.smartBookmarksVersion) → Add UI to restore Smart Bookmarks queries (reset browser.places.smartBookmarksVersion)

Comment 11

11 years ago
I agree, there should be some way to restore that smart bookmarks folder without going to about:config. I managed to find a solution on Google, and for me it's not a problem to edit some secret registry - I'm a Linux user, so I'm used to that; but the problem is, that an average user probably won't be able to find that, and we have to think about them too...
This is far too narrow of a case to deserve UI in the product, but instead should be added to the user documentation. Adding flag requesting documentation.

(In reply to comment #9)
> Re-added; though I'll admit it kinda sucks that you can lose these queries and
> never get 'em back.

You can get them back by resetting the aforementioned pref.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: uiwanted → user-doc-needed
Resolution: --- → WONTFIX
user-doc-complete
Hehe, we've actually had a doc for this since last June. :-)
<https://support.mozilla.com/kb/Restore+the+default+Smart+Bookmarks+Folders?bl=n>
Keywords: user-doc-needed → user-doc-complete
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
Duplicate of this bug: 547953
You need to log in before you can comment on or make changes to this bug.