/tmp-1 could not be saved, because you cannot change the contents of that folder.

VERIFIED FIXED in Firefox 3 beta1

Status

()

Firefox
File Handling
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: Tuukka Tolvanen (sp3000), Assigned: Mardak)

Tracking

({regression})

Trunk
Firefox 3 beta1
x86
Linux
regression
Points:
---
Bug Flags:
blocking-firefox3 +
in-litmus ?

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
linux firefox trunk 2007-10-13-19Z

        Downloading /tmp-1

        /!\ /tmp-1 could not be saved, because you cannot change the contents
            of that folder.

            Change the folder properties and try again, or try saving in a
            different location.

                                                                        [OK]

case one: at https://bugs.maemo.org/show_bug.cgi?id=693#c7 middle click attachment

case two: at http://tablets-dev.nokia.com/d2.php left click on rootstrap_..._v2.2 (it probably wants you to click a button or such to set a cookie first)

not readily reproducible.

Comment 1

10 years ago
I've seen this a couple of times too in the last few days. Usually trying to download the file again fixes the problem when it occurs.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a9pre) Gecko/2007101704 Minefield/3.0a9pre

Updated

10 years ago
Keywords: qawanted

Updated

10 years ago
Flags: blocking-firefox3?
I see this, too.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a9pre) Gecko/2007102004 Minefield/3.0a9pre

Comment 3

10 years ago
I'm having trouble reproducing this.  The steps to reproduce here are pretty vague.  Can you post in fairly explicit detail exactly the list of actions / clicks that leads to this error?  In particular, I'm trying to understand if/how the filepicker is involved here.

Comment 4

10 years ago
I can usually reproduce it by setting "Always ask where to save files", then initiating several downloads in sequence. Usually, the 2nd or 3rd simultaneous download will result in the /tmp-1 error instead of the file picker.
Blocking for investigation ... can someone figure out what's causing this, please?
Flags: blocking-firefox3? → blocking-firefox3+
(Assignee)

Comment 6

10 years ago
This should be fixed by bug 402298.
Assignee: nobody → edilee
Depends on: 402298

Comment 7

10 years ago
(In reply to comment #6)
> This should be fixed by bug 402298.

I tried to download files many times
but I can't reproduce with today's build.
I think this is fixed too.
(Assignee)

Comment 8

10 years ago
-> Fixed per comment #7.

If there's a general download litmus testcase per platform, this could work well for linux as on other platforms, the parent of the temp directory is generally user writable. "download a bunch of open-with files" (On linux, does the error show up right away during/before the open-with dialog? That could simplify testing if the user can just start and cancel downloads instead of waiting for them to finish.)
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Flags: in-litmus?
Keywords: qawanted → regression
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3 M9
My brother Jeff emailed me a few days ago, telling me he experienced this bug on a daily basis, and that the recent nightlies (running under Ubuntu Linux) have indeed fixed this.

My own testing--and others--confirms this to be true, using:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a9pre) Gecko/2007110604 Minefield/3.0a9pre

Verified FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.