[About dialog] Remove modality or display links within

RESOLVED WORKSFORME

Status

P3
normal
RESOLVED WORKSFORME
19 years ago
10 years ago

People

(Reporter: BenB, Unassigned)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
Reproduce:
1. Enable user_pref("browser.show_about_as_stupid_modal_window", true);
2. Help | About Mozilla
3. Click on "Mozilla Public License"

Actual result:
It opens in a browser window, which is not accessible, because the about dialog
is modal. You have to closoe the dialog to access the link.

Expected result:
The page is immadiately accessible. Either
- open it in the dialog or
- remove the modality.

BTW: It would be cool, if "Conntributors" in the "About" pane would open the
"Contributors" pane, but I don't think, that's easy without dropping to open
"about:".
(Reporter)

Comment 1

19 years ago
Also change the pref to "browser.use_about_dialog".
(Reporter)

Updated

19 years ago
Blocks: 40023

Comment 2

19 years ago
The major problem with removing the modality and displaying pages linked
from the about dialog in the browser window from which it was launched is that,
after switching away from the dialog it will be effectively buried. And once
the user presses [Back] to get back to whatever page had been displayed, there
will be no reminder that the about dialog was ever displayed. To top it off,
all of this is navigationally non-obvious to beginners.

Better by far to display the pages linked from the about dialog within it.
Summary: [About dialog] Remove modality → [About dialog] Remove modality or display links within

Comment 3

19 years ago
Created attachment 8942 [details]
Last line change for useaboutdialog

Comment 4

19 years ago
Created attachment 8943 [details]
Rest of changes to get to useaboutdialog pref

Comment 5

19 years ago
forget that last attachment. it doesn't view right. but changes are needed to 
the pref-debug.xul file to get useaboutdialog to work
(Reporter)

Comment 6

19 years ago
sidr,
opening links in the about window doesn't come for free either. Or do you want
to browse in the about dialog?

Comment 7

19 years ago
No, I don't want to browse there, but opening links in a window the dialog
is partly obscuring, messing up the naive user's sense of "where am i" in the
process, does not seem sensible. Displaying content in the parent window is
just confusing.

If the links in the about dialog can't be displayed within it, they should
open in a new, popup window with no UI except a way to destroy that window.
Yes, this is clunky, but no more than going modeless and using the parent
window, and this way it is obvious to everyone what's what. 

That's not free, but on the coding side it's easy: just a bit of js in the HTML.

In fact, if the links in the about dialog are displayed within it, or in a
popup, there is no reason not to go modeless as well. 

Changing QA contact to Matthew Thomas; this is more his area.
QA Contact: jelwell → mpt

Comment 8

19 years ago
Oooo, tricky. Very tricky indeed.

About should definitely appear in a dialog, regardless of what previous versions 
of Mozilla have done. It is just as inappropriate to clear the current content in 
the main app window, and replace it with About information, in a Web browser as 
it would be in a word processor.

I think the license is an intrinsic part of the `about' realm of the software, 
and should be included in the About dialog itself. As for any links in the About 
dialog, I think that the best idea would be to *close* the About dialog whenever 
a link in it is clicked, and then go to that page in a browser window.

CCing Matthew Tuck -- the modal about dialog was your doing, wasn't it?

Updated

19 years ago
Blocks: 5921
(Reporter)

Comment 9

18 years ago
Current state is that the page opens within about dialog. IMO, we should
- remove the modality (as suggested in bug ) and
- open a new browser window, if a link is activated.

I have no idea how to implement it, given that we have no control over the
content (we display about: and about:credits, which are generic URLs and should
stay that way), so we cannot code that into the <a> elements of the page displayed.

Michael Loew, are you still alive? If you don't want to / can fix this bug,
please reassign.
Component: Browser-General → XP Apps

Comment 10

17 years ago
The UI for the About dialog pref has been removed, and the implementation will
soon be removed as well.  The whole idea of a pref for this is silly.  Either
we'll keep the current behavior, or we'll switch to a modal dialog.  Since this
functionality is going away, marking this invalid.  We'll probably revisit the
About dialog issue at some point later on, but there's no telling whether bugs
like this will still exist in a new implementation.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 11

17 years ago
This bug was valid when filed. Stop abusing INVALID.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Reporter)

Comment 12

17 years ago
Besides, who removed the about dialog and why?
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 13

17 years ago
mpt wrote:
> About should definitely appear in a dialog, regardless of what previous versions 
> of Mozilla have done.

Anyone feel free to open.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(Reporter)

Comment 14

17 years ago
ops. I did it myself accidently. Sorry for the spam.

Comment 15

17 years ago
If this bug is to make About open in a modal dialog, then it's valid, and should
remain open.  But it doesn't seem like it handles this issue.

"Valid when filed" does not mean a bug is valid forever.  The description of an
invalid bug is "The problem described is not a bug."  Indeed, the problem as
described here cannot be a bug if a modal About dialog does not (or will not) exist.

> Besides, who removed the about dialog and why?

Samir, I believe, removed the About dialog pref. Consequently, I will soon
remove the backend.  When a decision has been made about the behavior of the
About dialog, we'll tackle the issue.

Personally, I wouldn't mind if About opened in a dialog. That's not the point. 
The point is that what we have now is a half-assed hidden implementation that
serves no purpose.  What we need is a decision on the ultimate behavior, and
then  a bug to track the work, with an implementation that's done properly, and
is not prefable.

As an aside, I welcome and value Matthew's UI advice, but he is not the
decision-maker.  (This is not intended to start a "UI ownership" war; in
reality, no one except a module owner and peers should be able to make a
decision about something.)

Unless this bug is to show Mozilla in an About dialog, please don't reopen this
without solid reasoning.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 16

17 years ago
> Matthew [...] is not the decision-maker.

Is there is any single person being the decision-maker about Mozilla UI
questions, he is it.

> "Valid when filed" does not mean a bug is valid forever

It does.

> Personally, I wouldn't mind if About opened in a dialog. That's not the point. 
> The point is that what we have now is a half-assed hidden implementation that
> serves no purpose.  What we need is a decision on the ultimate behavior, and
> then  a bug to track the work, with an implementation that's done properly,
> >and is not prefable.

I think that most people agree that the About shuold be a dialog, if we have a
good implementation. We have a half-baked implementation, and this bug is the
most important one to make it good.

Deleting an implementation that is on the right path, just because it's not far
enough, is not the right path of action. If we applied that to all of Mozilla,
we'd have deleted it 2 years ago.

The right path of action of not to remove the existing implementation, but to
fix it. This bug is the most important part of the "fix it".

Please don't close this bug as invalid.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 17

17 years ago
> Is there is any single person being the decision-maker about Mozilla UI
> questions, he is it.

There isn't.

> It does.

It most certainly does not.  Things change in Mozilla at a rapid pace; what's
valid one day might not be the next.  What would you expect to bugs on the
bookmark manager if we removed that window?  Your having bugzilla permissions is
questionable if you don't grasp this.







(Reporter)

Comment 18

17 years ago
> What would you expect to bugs on the
> bookmark manager if we removed that window?

WONTFIX.

> Your having bugzilla permissions is questionable if you don't grasp this.

IMO, your bugzilla permissions are questionable, if you keep closing valid bugs
as invalid.

BTW: You say yourself that the code is still in CVS (so this bug is still
valid), and it believe it should stay there.
Please cite the relevant bug numbers about the removal of the pref and the code
here.

Comment 19

17 years ago
> WONTFIX.

Well, your expectation is wrong!  WONTFIX is for bugs that are not going to be
fixed because the module owner or peer has decided it's not in the best interest
of the product.  INVALID means, at the moment it's marked as such, the bug is
not valid.

I will leave about.xul in the tree. 
(Reporter)

Comment 20

17 years ago
> WONTFIX is for bugs that are not going to be fixed because the module owner or
> peer has decided it's not in the best interest of the product.

That's exactly what happens.

> INVALID means, at the moment it's marked as such, the bug is not valid.

I disagree.

I filed bug 125637 about a better definition on INVALID.

> I will leave about.xul in the tree. 

Thanks.

Comment 21

17 years ago
See also bug 79210 and bug 109308.

Whatever the decision is, we should only support one kind of About, page or
dialog. There's no sense in supporting more than one. It's not such an important
function that we need more than one way of doing it.

-> nobody
Assignee: michael.lowe → nobody
Status: REOPENED → NEW

Comment 23

16 years ago
about box appears in a dialog, and I click to open the new window from the link,
but then I cannot close the dialog (don't know yet if I can close it after I
close this new window)
I suggest marking this works-for-me.

I did the steps and the link now open inside the about box.
Product: Core → Mozilla Application Suite
Status: NEW → RESOLVED
Last Resolved: 17 years ago10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.