Inconsistent parsing of <a><div>...</div></a>

RESOLVED DUPLICATE of bug 324875

Status

()

Core
HTML: Parser
RESOLVED DUPLICATE of bug 324875
11 years ago
11 years ago

People

(Reporter: Doug Shea, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a9pre) Gecko/2007101804 Minefield/3.0a9pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a9pre) Gecko/2007101804 Minefield/3.0a9pre

All the titles of the strip on this page should be a large bold yellow-ish color; however, the title for strip #297 is a small bold red color. The source for this title is exactly the same as others on the page, generated by the same script and using the same CSS. The title of this strip looks correct in other browsers, such as Safari and Opera, but incorrect in Firefox and Camino.

Reproducible: Always

Steps to Reproduce:
1. Load http://ver3.sundayat10.com/archive.php?num=289
2. Scroll down to the June 18, 2007 comic.

Actual Results:  
The title of that one comic is small, bold, and red.

Expected Results:  
The title of that comic should be like all the rest, large, bold, and yellow-ish.

Comment 1

11 years ago
I can reproduce the bug as described.  Looking at the page with DOM Inspector, I see
   A
     DIV
for the titles that look "good" and
   A
   DIV
     A
for the title that looks "bad".  

Firefox's handling of this invalid HTML is inconsistent.  I think this is the "if the TCP/IP packet boundary happens to fall in the wrong place" case that http://ln.hixie.ch/?start=1138169545&count=1 alludes to.   I'll attach a testcase that demonstrates something similar using document.write but I'm not sure it tests the right code.

This is definitely a bug in Firefox's HTML parser, but the workaround for the webmaster is easy: make the markup be <div><a>...</a></div> instead of the invalid <a><div>...</div></a>, and style the <a> element with "display:block" if you want the space to the right of the text to be clickable.
Status: UNCONFIRMED → NEW
Component: Style System (CSS) → HTML: Parser
Ever confirmed: true
QA Contact: style-system → parser
Summary: Not using the correct font/text style (no apparent difference from elements surrounding it) → Inconsistent parsing of <a><div>...</div></a>

Comment 2

11 years ago
Created attachment 285423 [details]
testcase using document.write
This is either a dupe of bug 324875 or depends on bug 328930.

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 324875
You need to log in before you can comment on or make changes to this bug.