Make nsHTMLTokenizer::ScanDocStructure deterministic

RESOLVED FIXED in Future

Status

()

RESOLVED FIXED
13 years ago
8 years ago

People

(Reporter: mrbkap, Unassigned)

Tracking

Trunk
Future
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by the HTML5 parser])

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
jst and I were talking about this a while ago, and this has now come up again on the WHATWG mailing list. Currently ScanDocStructure will take anything it's given and send it back out, leaving decisions about what is "unknown" and "malformed" to where packet boundaries lie, etc. We should make it require a fixed number of tokens to do its work, so while it won't be perfect, it'll be deterministic, which is better than what we have now.

Someone (ahem) should probably do some sort of measuring to see what a good number of lookahead tokens is that balances good decisions against speedy rendering.
(Reporter)

Updated

13 years ago
Target Milestone: mozilla1.9alpha → Future
Created attachment 255048 [details]
testcase

This uses an empty script element to simulate a packet boundary, and is equivalent (other than s/packet boundary/script/) to the problem that's been bugging people about the output of the testing tinderboxes (pre-bug 370344).

If you wanted to add this to reftest, the reference would be the same testcase without the script element (which produces the results described).
Note also that some approaches to fixing this bug might not fix the testcase in comment 1, although I believe the approach in bug 328930 (implementing the WHATWG spec's error handling) would.
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> Note also that some approaches to fixing this bug might not fix the testcase in
> comment 1, although I believe the approach in bug 328930 (implementing the
> WHATWG spec's error handling) would.

I think that, in this case, we'd consistently not have the desired behavior here (that is, the <tt> would have no effect), but you are correct that bug 328930 would present the desired effect.

Updated

11 years ago
Duplicate of this bug: 400307

Updated

10 years ago
Duplicate of this bug: 467395
(Reporter)

Updated

10 years ago
Duplicate of this bug: 464583

Updated

10 years ago
Duplicate of this bug: 466843

Updated

10 years ago
Duplicate of this bug: 475034

Updated

10 years ago
Duplicate of this bug: 286048

Updated

10 years ago
Blocks: 273543

Updated

10 years ago
Duplicate of this bug: 435310

Updated

10 years ago
Duplicate of this bug: 457765

Updated

10 years ago
Duplicate of this bug: 497729
(Reporter)

Updated

9 years ago
Assignee: mrbkap → nobody
(Reporter)

Updated

9 years ago
Duplicate of this bug: 526482

Updated

9 years ago
Duplicate of this bug: 532864

Updated

9 years ago
Duplicate of this bug: 491789

Updated

9 years ago
Depends on: 373864
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Whiteboard: [fixed by the HTML5 parser]

Updated

8 years ago
Duplicate of this bug: 527414

Updated

8 years ago
Duplicate of this bug: 597526

Updated

8 years ago
Duplicate of this bug: 627203
You need to log in before you can comment on or make changes to this bug.