Last Comment Bug 400463 - firefox-2.0.0.8 build break due to relocation error on amd64 - missing system header
: firefox-2.0.0.8 build break due to relocation error on amd64 - missing system...
Status: VERIFIED FIXED
: verified1.8.1.10
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: 1.8 Branch
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Walter Meinl
:
: Gregory Szorc [:gps]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-19 14:45 PDT by Walter Meinl
Modified: 2007-11-21 01:15 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
add gdkpango.h to system-headers (1.10 KB, patch)
2007-10-19 14:49 PDT, Walter Meinl
roc: review+
dveditz: approval1.8.1.10+
Details | Diff | Splinter Review

Description Walter Meinl 2007-10-19 14:45:53 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.8.1.8) Gecko/20071019 Firefox/2.0.0.8
Build Identifier: 

bug349906 was ported back to the 1.8 Branch. Now, the brandnew downloaded firefox-2.0.0.8 sources fail to compile due to gdk/gdkpango.h missing from the system headers with a relocation error output
For the error message see http://bugs.gentoo.org/show_bug.cgi?id=196444

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 Walter Meinl 2007-10-19 14:49:57 PDT
Created attachment 285522 [details] [diff] [review]
add gdkpango.h to system-headers

The patch also corrects the configure check for pango pc files as pangoxft is not needed anymore after the branch checkin for bug349906 and therefore why should we check for it?
Comment 2 Walter Meinl 2007-10-19 14:52:31 PDT
the same header was already added to the the trunk system-headers in bug362682
Comment 3 Walter Meinl 2007-10-19 14:54:26 PDT
hrrmm, sorry, missed to add an important information the build breaks only with gcc >= 4.2
Comment 4 Daniel Veditz [:dveditz] 2007-11-07 14:39:27 PST
Comment on attachment 285522 [details] [diff] [review]
add gdkpango.h to system-headers

approved for 1.8.1.10, a=dveditz for release-drivers
Comment 5 Reed Loden [:reed] (use needinfo?) 2007-11-08 01:03:51 PST
MOZILLA_1_8_BRANCH:

Checking in configure.in;
/cvsroot/mozilla/configure.in,v  <--  configure.in
new revision: 1.1503.2.106; previous revision: 1.1503.2.105
done
Checking in config/system-headers;
/cvsroot/mozilla/config/system-headers,v  <--  system-headers
new revision: 3.4.4.4; previous revision: 3.4.4.3
done
Comment 6 Al Billings [:abillings] 2007-11-15 16:23:52 PST
Walter, can you verify that this is fixed?
Comment 7 Walter Meinl 2007-11-21 01:15:22 PST
(In reply to comment #6)
> Walter, can you verify that this is fixed?
> 
Yes, thanks to all helping to get this in

Note You need to log in before you can comment on or make changes to this bug.