"BACKSPACE" should do "BACK" on linux platforms

RESOLVED WONTFIX

Status

()

--
major
RESOLVED WONTFIX
11 years ago
6 years ago

People

(Reporter: mnemo, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8

I just installed Ubuntu Gutsy Gibbon and found out that the BACKSPACE does not navigate "BACK" to the previous webpage. I saw that you previously changed this due to "platform consistency" but this is no true anymore. I looked around in the programs that ship with ubuntu and all of them use BACKSPACE for BACK. One of the most important examples is the GNOME file manager.

Many windows will refuse to migrate to linux if they have to re-learn all their shortcut keys (and probably still keep using the "normal" keybinding at work etc for a pretty long time).

Please change BACKSPACE to BACK.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 358764

Comment 2

11 years ago
A bug asking to revert a retargeted bug cannot be duplicate of the latter.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Updated

11 years ago
OS: Windows 2000 → Linux
Version: unspecified → Trunk

Comment 3

11 years ago
(In reply to comment #0)
> ... use BACKSPACE for BACK.
> One of the most important examples is the GNOME file manager.

No, you have misunderstood what the GNOME file manager actually does,
it navigates to parent directory, ie. adds a new history entry for it,
try clicking Back after typing BACKSPACE and you'll see what I mean.

FWIW, I've just upgraded to Kubuntu 7.10 and Konqueror doesn't go back
when typing BACKSPACE, it does nothing.  Likewise for the GTK file
dialog and the browser in the KTorrent application.

Bug 358764 contains the discussion that lead to the current behaviour.
I don't see any changes in Gutsy at this point that would support
changing this again.
What Mats said.  I'm not going to resolve it (not my product, etc), and I'm not going to retype all the things that got said in bug 358764.  I'm just tired of people pushing this thing over and over and the decision having to be remade over and over.  Incredible waste of everyone's time.

Comment 5

11 years ago
Created attachment 290726 [details] [diff] [review]
a fix making backspace behavior uniform across all platforms

This patch fixes the problem. Now backspace behavior is the same for all platforms. It goes back, as it should, and as was requested by oh so many linux users. I hope this gets in to 3.0.

Comment 6

11 years ago
(In reply to comment #4)
> and I'm not
> going to retype all the things that got said in bug 358764.  I'm just tired of
> people pushing this thing over and over and the decision having to be remade
> over and over.  Incredible waste of everyone's time.

Why can't you just go with what the users want?  Why is bug 358764 closed as "should do nothing"?  Incredible waste of users' time to force them to find the fix online and then manually edit their about:config to get back their normal familiar functionality.  Many Firefox users aren't even technical enough to handle this.
(Reporter)

Comment 7

11 years ago
Great work Elez J. Shenhar! I'm very glad that you took the time to create this patch. I do believe that this is what most people want.

Comment 8

11 years ago
I hate this function, always accidentally bring me back to previous page when i am filling in some form. I hope it can be disable by default!!

Comment 9

11 years ago
(In reply to comment #8)
> I hate this function, always accidentally bring me back to previous page when i
> am filling in some form. I hope it can be disable by default!!
> 

Yes, I too hate it so much when buttons are pushed on my keyboard and they do things I don't want.  To solve this I usually do one of the following: move my 4-month old away from the keyboard OR start paying attention to what I'm doing. It works, even with the backspace button enabled!

Comment 10

11 years ago
As Bug 358764 is marked as "fixed" and now suddenly is a completely different bug, than submitted, I'm kind of crossposting this suggestion to here:

My feeling is, that this is mainly a matter of taste - some just
want to have a simple single-key shortcut to go back (how about "Del" if
Backspace is a poor choice? It "does nothing" right now and is hardly used for
correction during typing) so the "best" alternative would be what someone
already suggested - on the first use of "Backspace" outside a text field, the
user should be asked what behavior he wants (do nothing/back in history/page
up). As obviously different users want different behaviors and even have a
strong opinion on this, the best way would be to ask them - saving them the
effort to google for a fix that leads to the behavior they want. 

Asking people in a pop-up might generally be poor style - but this issue has been messed up already by changing the behavior of the keys (changing a key setting that people have gotten used to is "poor style" in it's essence), and now groups of users with very clear preferences in the matter have been created and this seems to be the only way out to reduce annoyance for everyone to a minimum.  

K.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.