Closed Bug 400588 Opened 12 years ago Closed 12 years ago

animated gif is broken (no need to reload)

Categories

(Core :: ImageLib, defect, major)

defect
Not set
major

Tracking

()

VERIFIED FIXED

People

(Reporter: Peter6, Assigned: pavlov)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007102102 Minefield/3.0a9pre ID:2007102102

repro:
open FF
open URL
press on any link containing the word "loop"

result:
the image won't animate

regression window:
works in 20071018_1724_firefox-3.0a9pre.en-US.win32
fails in 20071018_1740_firefox-3.0a9pre.en-US.win32

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=PhoenixTinderbox&branch=HEAD&branchtype=match&filetype=match&whotype=match&sortby=Date&hours=2&date=explicit&mindate=1192753440&maxdate=1192754399&cvsroot=%2Fcvsroot

-> bug 296818

note: this is kind of the same as bug 400403, except that you don't need to reload, it fails right away.
Flags: blocking1.9?
(Although I think this is probably a dupe of bug 400403, even if the STR differ slightly.)
Attached patch fixSplinter Review
the previous patch got rid of a temp variable that was set at the top and checking mFrames.Count() == 1 at the bottom needed to be == 2 without it.

this basically just reverts us back to where we were with better comments and without the regression.
Attachment #285740 - Flags: review?
Flags: blocking1.9? → blocking1.9+
Attachment #285740 - Flags: review? → review+
Comment on attachment 285740 [details] [diff] [review]
fix

Regression fix, a=beltzner
Attachment #285740 - Flags: approval1.9+
checked in.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Duplicate of this bug: 400403
Assignee: nobody → pavlov
OS: Windows XP → All
Hardware: PC → All
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007102209 Minefield/3.0a9pre ID:2007102209

VERIFIED

thanks Stuart
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.