Add API call: list recommended addons

RESOLVED FIXED in 3.3

Status

addons.mozilla.org Graveyard
API
RESOLVED FIXED
11 years ago
2 years ago

People

(Reporter: laura, Assigned: laura)

Tracking

unspecified

Details

(URL)

(Assignee)

Description

11 years ago
 
(Assignee)

Updated

11 years ago
Duplicate of this bug: 400716
(Assignee)

Comment 2

11 years ago
Functionality added in [7880].  Unit test needed.

Updated

11 years ago
Blocks: 404024
I think the current form of this API is not all that useful. Rather than just returning a set of ids I think it would be better to return the full <addon> record from bug 399913 otherwise callers will just have to do multiple calls before they get anything useful.
I suspect this is something to do with caching, but there doesn't seem to be any randomness to the results if I repeatedly request say 5 items.
(Assignee)

Comment 5

11 years ago
Giving full details fixed in r8680.
(Assignee)

Comment 6

11 years ago
Caching bug fixed in r9517.
(Assignee)

Updated

11 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
It looks like the change to fix the caching has just broken the recommended list. The response includes the <cake:nocache> element and since there is no cake xml prefix named this just makes the xml invalid. The caching also still appears to be happening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 8

11 years ago
r9692 fixes this.
Status: REOPENED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.