Closed Bug 400808 Opened 13 years ago Closed 12 years ago

Google re-invites all attendees of an event when an invitation is accepted

Categories

(Calendar :: Provider: GData, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 407961

People

(Reporter: imexil, Unassigned)

References

Details

(Whiteboard: [gdata-0.3.1])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; nb-NO; rv:1.8.1.6) Gecko/20071008 Ubuntu/7.10 (gutsy) Firefox/2.0.0.6 Mnenhy/0.7.5.666
Build Identifier: TB 2.0.0.6 (20071008), Lightning (2007102104), gdata provider (latest nightly 20070925)

When I receive an invitation from someone in TB and click the accept button. It is added to my Lightning calendar and synced correctly to the Google Calendar. So far so good. The problem now is that Google starts to re-invite all attendees to the just accepted invitation. 
I'm not quite sure if this is a bug in gcal or in gdataprovider.

Reproducible: Always

Steps to Reproduce:
1. Get a friend to send you _and_ some others an invitation 
2. Accept the invitation into an Google-Synced calendar

Actual Results:  
You (and all other attendees) should receive another invitation from *your* google account for the very same event.

Expected Results:  
You (and the other atendees) should NOT receive another invitation.
Just tested the new nightly of gdata provider (gdata-provider-2007-10-22-13.xpi) but the problem stays the same.
Invitations is a bit tricky.

The item added probably has a different id than the item from the invitation. I'm not sure if its possible to specify the id of the item when adding it. Also, I guess I have to differ whether the item is an invitation or not.

Anyway, as a small workaround, you can totally disable sending invitations setting the "calendar.google.sendEventNotifications" preference to false.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Yes over lunch I thought about it for a bit and came to a similar conclusion. You are right, the invitation is actually sent to a different id (i.e. mail address) then the google-account is. Thanks for the workaround!
I cannot see calendar.google.sendEventNotifications in the advanced config editor. Which type of pref should I insert?
It's not present by default. Simply add it by right click and then choose New -> Boolean and give that boolean the name 

calendar.google.sendEventNotifications

and set it to false.

/HeX
Thanks, I just needed a reassurance on the type of pref to insert.
One could guess it was a boolean, but obviously having an authoritative indication is much better.
Duplicate of this bug: 401282
Flagging "blocking‑calendar0.8?", as this bug is a regression and a pretty huge annoyance to users and to the people they re-invite to duplicate events.
Flags: blocking-calendar0.8?
Spammed my whole office with this.

Please fix this & don't release unless it does not happen by default.

I will not use this extension again because of the pain this caused, but if it is fixed maybe other people will use it.
I'll be defaulting this to false in the next version, which I expect to come out this week.

Daniel, we are using the wanted flags to find out what is wanted for the next version and blocking flags to flag such bugs that really block the release. I don't know if these flags are the right thing for gdata since the release process is independent of the Sunbird/Lightning release schedule.

I will consider actually fixing this (not only changing the default) in the timeframe for 0.8 though.
Flags: blocking-calendar0.8? → wanted-calendar0.8+
Very much looking forward to seeing this bug fixed, as I had a similar experience as Erik
For what it's worth: The duplicate invitation problem is fixed on my machine, using Lighting 0.7 and Provider for Google Calendar 0.3.1 and using the workaround from Comment 5.  (not sure if the workaround is still necessary, or if GCal Provider 0.3.1 made it unnecessary)

HOWEVER, this related problem still remains: 
  If the original invitation has "send email reminder" turned on, that setting is preserved in the duplicate event created in my Google Calendar.

  So my Gmail account ends up spamming all of the invitees with reminder emails for my Google Calendar copy of the event.
Daniel: did you post this as a new bug as it is related but not the same as this one? Because I have this very same issue, and it is very annoying.

If you haven't and didn't find another bug like it, I will be glad to create the report.

Philipp: have you looked at Daniels description of the related problem? Would you prefer it handled in a new report? Do you otherwise have any comment of the nature of this problem - as it is not really a bug as much as a (mis)feature.
Feel free to reuse this bug, changing the summary to reflect the issue. I think I haven't quite understood the problem.

Where is  "send email reminder" turned on? Is this in Lightning UI? It sounds to me like the alarm is passed on to google, but I have no support for email alarms, only popup alarms. Therefore Google should not be sending out emails?
Also, I am interested if people that used 0.3 for the short time it was out and then upgraded to 0.3.1 automatically had the sendEventNotifications option turned off.
(In reply to comment #15)
> Also, I am interested if people that used 0.3 for the short time it was out and
> then upgraded to 0.3.1 automatically had the sendEventNotifications option
> turned off.

I can confirm, that this worked just fine :)

I am currently reviewing the exact VCALENDAR-invites, that will create this problem and exactly how they are created in Google Calendar. I will get back to you, when I have precise instructions to re-create.

And for the love of something, I cannot figure out how to chance the title of this bug? If I press edit, I just get an extra line, but there is no input field? Well, it can wait until I know what the exact problem is.
Any update on this bug? I'd love to re-enable my Google calendar soon...
I await your testing :)

Generally, version 0.3.1 should not send event notifications by default. This needs extra enabling. If this is not so, please comment! If it is, please also comment

The open issue seems to be that google sends email reminders to attendees if an alarm is set. Is this correct?  Maybe we *should* close this bug and make a new one, I'm a bit confused.
Correct, I'm still seeing the reminder problem.  I am using 0.3.1, and the notifications are working properly.  But it still sends out reminders to everyone on the invite list.

I don't know how this is happening, but perhaps a setting to disable reminders would be called for?

Thanks!
I have no way to differ between incoming invitations and events created in the dialog, therefore its hard to disable reminders for invitation events.

I still wonder why email alarms are enabled? I have not added the code to allow selecting the alarm type, so the alarm should be a popup alarm or none at all.

Do you have email as a default setting? with calendar.debug.log enabled, what is the xml line of the event created when you accept the meeting, containing <gd:reminder> ? Better yet, post the whole xml event that is uploaded to google.

Is the new summary a fitting description of the Problem?
Summary: Google re-invites all attendees of an event when an invitation is accepted → Google sends email reminders to all attendees
I have not tracked the issue down to any certain setting. But the issue is, that if someone using Outlook 2007 sends a reminder, and I then add it to my Google Calendar using this provider, in my Google Calendar it seems like as if I sent the original invitation and 24 hours before the event, Google Calendar will send out a reminder to the rest of the invited attendees - but not to the original sender nor to me.

I have narrowed down 2 VCALENDAR invites - 1 from Outlook 2003, that does not send the reminder, and another for Outlook 2007 that does send the reminder. I cannot see which part of the 2007 invite, that enables this "send reminder" feature.

2003-version not sending reminder: http://www.barklund.org/examples/2003_invite.txt
2007-version sending reminder: http://www.barklund.org/examples/2007_invite.txt

(private details removed)

In the latter, theres a huge section about the timezone, but that cannot matter? The VALARM-section in the two invites are the same. My best guess would be the "PARTSTAT=NEEDS-ACTION" which is part of the ATTENDEE-nodes. But I do not know the format of VCAL-stuff, so I am only guessing.

Should we move to a new bug?
Contining discussion in bug 407961. Original issue fixed by defaulting sendEventNotifications to false in version 0.3.1
Status: NEW → RESOLVED
Closed: 13 years ago
Flags: wanted-calendar0.8+
Resolution: --- → FIXED
Summary: Google sends email reminders to all attendees → Google re-invites all attendees of an event when an invitation is accepted
Whiteboard: [gdata-0.3.1]
The patch included in 0.3.1 was never checked into cvs. here it is, checking in on moz1.8 and head now.
Attachment #294659 - Flags: review+
I have experienced this problem several times (without realizing it until someone finally let me know) using Lightning 0.7 and Provider 0.3.1.  After reading this bug, I confirmed that calendar.google.sendEventNotifications was set to false -- and has been since I installed version 0.3.1 on the day of its release.  So since this behavior is seen with sendEventNotifications set to false, I don't think this bug has been fixed (at least not in all cases).

Here's what has happened to me (again, multiple times):

1.  Someone sent an Outlook meeting invite (including me and several other invitees) to my work address, which I received via Thunderbird 2.0.0.9, with Lighting 0.7 + Provider 0.3.1.

2.  This showed up in Thunderbird/Lightning as an Event Invitation with "Accept" and "Decline" buttons.  I clicked "Accept", and selected my Google calendar to import into.  Of course, my Google calendar is tied to my gmail address, *not* my work e-mail address.

3.  The event was successfully imported into my Google calendar, but an invitation was sent out from my gmail address (*not* my work address) to all of the other attendees on the list.

My guess is that when the event was imported into Google, it thought I was creating a new event, with a list of invitees.  Hence, all of the original invitees (except for me at my work e-mail address, strangely) were sent an e-mail invite from my gmail address.

I would appreciate you reopening this bug, or commenting on how I can resolve this if I am doing something wrong.

Hello mmindenhall.

The discussion of this bug was moved to bug 407961. Its quite hard for me to really tackle this issue. It would be great if you could also send an outlook inivitation to me (mozilla at kewis dot ch). Schedule the event at least 3 days in the future, relative to the time you send it to me so I have time to respond and look into it.
This bug is about invitations, not reminders, which is what bug 407961 is about. I have sent you a test invitation.
Erik, sorry about the confusion of the bug title, you are of course right. I think the issues are either related or the same thing though.

Are you sure this is an invitation? Whats the subject of the invitation email you receive? I was now able to reproduce the reminder-24-hours-before issue myself, so I hope to fix at least that soon.

I'm reopening this bug too, just to make sure both issues are tackled.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I think it should be; it might send a different invite for people outside. I don't receive an invitation: could you forward it back to me?
I have found that its really hard to debug when I receive invitations from you guys, since I cannot retest if I have no luck with the first one. I think it would be better if you could post the XML of the event being added after accepting the invitation. Then I can feed that to google and see what happens.
Ok, here are my findings. I think this is all bug 407961 (maybe not by the bug title, but at least the bug content):


* If a non-google user is invited, this person will recieve a reminder 24 hrs before the event. This is a google bug and is already in their issue tracker

* With sendEventNotifications = false, no invitations of any sort are sent, except for the above mentioned reminder.


I'm going to close this bug for now, since I could not reproduce this error and I assume the cause is bug 407961. Please provide exact steps to reproduce so I can test this, then I will reopen/fix.
Status: REOPENED → RESOLVED
Closed: 13 years ago12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 407961
This is a very serious bug, that made me run into real trouble! You must not close it!

This is what happened:

I work in a big company. We use Microsoft Exchange Server and Outlook to organize meetings. I synchronize my Outlook Calendar by using ActiveSync with my mobile phone (windows mobile device with pocket outlook). Recently I synchronized my mobile phone with lightning by using BirdieSync. So all the scheduled meetings appear in lightning. In lightning I use a network calendar (google calendar), so all this scheduled meetings also appear in my google calendar.

And for every scheduled meeting a new invitation was sent to every participant of every meeting in my calendar. No matter whether the event is in the past or not! No matter who created the event (NOT me)!

Unfortunately one of the meetings was an information event for ALL the employees in the whole company (did I already write, that I work in a big company?)! So I sent an invitation mail to every employee in the whole company including the CEO. Perhaps now is the right time for me to go on a long holiday and after that I can cover my face by wearing a paper bag over my head, what do you think?

This happened yesterday and I used the most recent version of every involved software.


Regards
Ralf
Hello again,

I forgot to mention one thing:

When I wrote: "Recently I synchronized my mobile phone with lightning by using BirdieSync." ... This is about my PC at home.
Ralf, I'm sorry this has happened for you. After this has happened to a few people in earlier versions I made some precautions to stop this. Right now, accepting an invitation to a google calendar is not possible without setting an advanced preference. If someone sets this preference he or she should know what they are doing.

I agree your case is quite unfortunate, but there is not much I can do here. Your case happened since a different extension is synchronizing calendars. What they do is to add all items that are missing to the target calendar with all attendees. They use the same method that you might use to add a new event to your calendar, with attendees.

To really fix this bug, I need Google to step up and allow a few things that are currently not possible (i.e setting id and organizer manually when adding an item).

What I do have to offer, there is a preference to disable sending attendees to the server. It is called "calendar.google.enableAttendees" and is availabe in the advanced config editor. If you set this to false, then attendees will not be sent to the servers at all, and you shouldn't be inviting people.

At some point, I set this preference to true by default, but then again people complained that they could not add attendees. So no matter what I let the default set of options be, there will always be a downside.

I can't find the actual Google Issue regarding this bug, but please put pressure on Google instead so that I can get this bug fixed without breaking my back in workarounds.
Hello Philipp,


you wrote "Right now, accepting an invitation to a google calendar is not possible without setting an advanced preference.".

Can you please explain? I do not understand "accepting .. to" (I did not accept anything in google calendar) and I don't remember that I made any such setting. 

To avoid users running into this trap, your software should ask the user (in a dialog box or something) before you transmit the attendees for the first time. That dialog box should give a good explanation. And it should be big. And in red color. And it should contain a BIG warning sign. Your default behaviour is not O.K.

The main problem is, that the event was not newly created by me.
1. It was not new (another guy created it before and already sent the invitation to everybody).
2. It wasn't from me (so I'm not the one who wants to send invitations)

So the attendees should not receive an invitation.
With accepting I mean accepting as a result of getting an email invitation and then clicking "Accept" in the bar above the email message. This doesn't really have to do with your case, I just wanted to demonstrate that there have been problems in the past, due to the same Google bug.

About adding, synchronizing two calendars is nothing other than adding events that are not in calendar A to calendar B and vice versa, and some other operations. This means that birdiesync is adding a new event to your google calendar B, even though it may not be new on your calendar A.

I'm sure its possible to create a big warning the first time an event is added that contains attendees, but I must admit that given my responsibilities as the Calendar Team lead, I don't have time to dive back into all the workarounds related to this Google bug. Maybe someone else (you, possibly?) would like to step up and add this warning to the code.

Possibly another fix would be to check if the organizer set before the item is created in the Google Calendar is not empty and not the google user and then don't add attendees. I can't guarantee that the item BirdieSync is adding actually passes an organizer though.
Google Calendar CalDav connection with Thunderbird Lightning / Sunbird still has problems.
a very good description of these problems is written here : 
http://www.google.com/support/forum/p/Calendar/thread?tid=120732d111be2e52&hl=en
What is the conclusion here? Is it possible to Accept an invitation without sending re-invites? How?
(In reply to comment #38)
> What is the conclusion here? Is it possible to Accept an invitation without
> sending re-invites? How?

Matthias, this bug has been RESOLVED DUPLICATE. I suppose you should go read the comments to bug 407961 (which is FIXED).
This bug has absolutely not been resolved.  I again have had to purge lightning from my system because it and Google are combining to spam all invitees, and it looks as though events created by others are recreated by me.

I am using Google Apps, so perhaps the fix (if there is one) was only good for Gmail accounts.
I read the FAQ, and then all these comments, and am still unclear.  Can I set tbird up to 

a) accept invites to my google calendar  ( not a big problem if attendee information is lost on google version )
b) not spam invitees
c) still send the "accept" to the original organizer?

( tbird 3, lightning 1.0b1, gcal provider: 0.6b1 

Evolution seems to have this figured out, and I have had to switch back to evo for now.  ( but really prefer tbird! )  Perhaps their code can be examined for ideas on how to handle?
This bug has not been fixed, and neither has been 407961. Syncing Lightning calendar to Google calendar using the provider sends out Spam invites. TB3, Lightning 1.0b1.
Reading the comments and replies from Philipp it seems it cannot be fixed.  Its now over 2 years since first reported, so given that everyone has the same problem that according to Philipp requires Google to do something, maybe we close this, try another solution (is there?) and direct our efforts at Google.  

Philipp, raised the bug - lets all go vote on it http://code.google.com/p/gdata-issues/issues/detail?id=1082
This is still an issue. The bug listed above is no longer accurate, Google moved it here. Anyone reading this, please go and vote/bump up the bug: http://code.google.com/a/google.com/p/apps-api-issues/issues/detail?id=1079
This issue is not resolved. I've spent many, many hours trying to find a way around this. 
When I set calendar.google.sendEventNotifications to false then no one gets my meeting invites. I've tried everything!!!
Flags: needinfo?
Today I experienced the original issue - I received a company-wide invite to an event, clicked on "tentative" in Lighting, and then everyone in the company received an invite from me to the event. Great.

On day 2 of my "switch to Thunderbird/Lightning trial" I will be reverting back to Outlook because, sadly, it offers predictable behaviour when it comes to calendars.

Thunderbird 31.0, Lighting 3.3, Provider for Google Calendar 0.32
(other extensions include Google Tasks Sync 0.5.1, Signature Switch 1.6.12 and SmoothWheel 0.45.8 - just in case these might have any impact on the issue)
This is really odd, i never had any issues then a few months ago it started, and now won't stop.  It's a really big problem, making thunderbird 31.1.2 lightning 3.3.1 and Provider for Google Calendar 0.32 and google calendars totally unusable for me.  

It's not happening to my fellow the windows users.  I still want a calendar i can invite people to events to so the work around above doesn't seem to work. 

Anyone know is it thunderbird, lightning, google provider or google that the issue lies with?    
many thanks.
Okay,  SOLVED for me ! 

So it seems that it's Provider for Google Calendar.  For what ever reason the standard install version is 0.32, but you need to download and install version 1.0.1 from a website.  

So very annoying.  the bug is with google add-ons giving you the wrong version.
I'm still getting strange behaviour with google provider and thunderbird when I get invites and have got in a complete mess.  really shame.  Anyone know of the working reliable solution?
Are you getting the re-invitations mentioned here, or is it that you cannot accept invitations or dismiss alarms? Please stay tuned for 1.0.4 which is due very soon, it should fix everything.
Flags: needinfo?
I got the re-invitations mentioned then fixed the installation by going from 0.32 to 1.0.1, that seemed to work, but then I got one re-invitation issue and have been scared to use it ever since, manually adding the invites.  I have no way of testing as I don't have outlook that everyone who invites me seems to use. I will look out for it.
I've done some testing with a work colleague and the MS online outlook system you get with MS Live or some other random system they have.  And I'm not getting re-invites, being sent. I will do some more testing, but at present all seems good.  thanks.
You need to log in before you can comment on or make changes to this bug.