When you accept an event via Lightning into Google Calendar, duplicate invitations are sent out

VERIFIED DUPLICATE of bug 400808

Status

Calendar
E-mail based Scheduling (iTIP/iMIP)
--
major
VERIFIED DUPLICATE of bug 400808
11 years ago
10 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
I just upgraded to Lightning 0.7 and Google Provider 0.3, and I get a weird issue that I've never gotten before.  Not sure if it's a Lightning 0.7 bug or a Google Provider 0.3 bug.

Steps to reproduce:
 - Set up a Google Calendar account in Lightning
 - Accept an emailed invitation, and if you get a "Select Calendar" dialog, select your Google calendar.

Expected results:
 - A new event is created in google calendar, based on the invitation.

Actual results:
 - Same as expected results, PLUS: new invitations are automatically sent for your Google Calendar event to all invitees on the original event.  (on the behalf of your Google Calendar account)
 - You, as an inviteee, will also receive an invitation to this duplicate event.  And if you accept *that* into your google calendar, the process will repeat, with a new Google Calendar event being created and more invitations being sent out.


If it's relevant, here are more details about my setup:
 - I'm using Lightning for a non-gmail email account (my @mozilla.com one)
 - I already had my Google calendar set up for read/write access in Lighning 0.5, before the upgrade to 0.7.
(Reporter)

Updated

11 years ago
Summary: Google Calendar automatically sends out invitations to a new Google Calendar event, when you accept an event via Lightning → When you accept an event via Lightning into Google Calendar, duplicate invitations are sent out
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 400808
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: Lightning Only → E-mail based Scheduling (iTIP/iMIP)
QA Contact: lightning → email-scheduling
You need to log in before you can comment on or make changes to this bug.