mouse wheel scrolling doesn't work if scroll bar not visible

NEW
Unassigned

Status

()

Firefox
General
--
minor
10 years ago
4 years ago

People

(Reporter: Mikel Ward, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(firefox20 affected)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
The linked page opens a window with no scroll bars.  I can scroll down using the Down or Page Down key, but not using the mouse wheel.

1. Open http://www.news.com.au/feature/0,,5012863,00.html
2. Scroll down to ELECTORATEFINDER
3. Enter 3185 in the POST CODE SEARCH field and click the Show Electorate button
4. Click on the VIEW WEBSITE link next to Phillip Walker in the bottom right corner
5. Try to scroll the page down by using the mouse scroll wheel

(You may need to enable popups to complete these steps)

The window is opened using the following parameters to JavaScript's window.open function:
toolbar=0,scrollbars=0,location=0,statusbar=0,menubar=0,resizable=0,width=810,height=675

I assume mouse scrolling is somehow linked to the scroll bars.
(Reporter)

Comment 1

10 years ago
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.6) Gecko/2007100814 Ubuntu/7.10 (gutsy) Firefox/2.0.0.6
The page has gone, would you attach a testcase?

Updated

8 years ago
Duplicate of this bug: 551148

Comment 4

8 years ago
Created attachment 431516 [details]
testcase


Can not mouse wheel scroll when window.open without "scrollbars=yes"

On the other hand, the scroll with arrow key or PageUp/Down key is possible.
And Autoscroll works, too.

Steps to Reproduce:
1. Open test case
2. Click popuop button
3. Mouse wheel scroll

Actual Results:
 I can not scroll by wheel scroll

Expected Results:
 I can scroll by mouse scroll

Comment 5

8 years ago
This issue still exist on

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a3pre) Gecko/20100309 Minefield/3.7a3pre ID:20100309041426
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.2pre) Gecko/20100309 Namoroka/3.6.2pre ID:20100309041925
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.9pre) Gecko/20100309 Firefox/3.5.9pre ID:20100309040105
I think that this is designed in bug 259615.

dbaron, would you check this?

Comment 7

8 years ago
(In reply to comment #6)
> I think that this is designed in bug 259615.
> 
> dbaron, would you check this?

I do not think so.
There are not any 'overflow: hidden' style/attribute.
because there is no "scrollbars" in the argument.

See
http://mxr.mozilla.org/mozilla-central/source/layout/generic/nsGfxScrollFrame.cpp#1863

it makes overflow:hidden; internally.

Comment 9

8 years ago
If it is so, Scroll by keyboard or autoscroll should not be permitted, too.
Is it other bugs?
(In reply to comment #9)
> If it is so, Scroll by keyboard or autoscroll should not be permitted, too.
> Is it other bugs?

I forget the bug#, but smaug were working for the keyboard problem, I'm not sure for the other.

Comment 11

8 years ago
Anyway there is WORKAROUND( setting dom.disable_window_open_feature.scrollbars to true).
It is not a so big problem.
No reply, INCOMPLETE. Please retest with Firefox 3.6.x or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 13

8 years ago
Sorry, I thought Alice0775 White's comments were sufficient.

Yes, so it sounds like Mozilla's default for scrollbars is no

https://developer.mozilla.org/en/DOM/window.open
"If you define the strWindowFeatures parameter, then the features that are not listed, requested in the string will be disabled or removed (except titlebar and close which are by default yes)."

Whereas Internet Explorer's default is yes
http://msdn.microsoft.com/en-us/library/ms536651(VS.85).aspx
"scrollbars = { yes | no | 1 | 0 }
Specifies whether to display horizontal and vertical scroll bars. The default is yes."
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
(Reporter)

Comment 14

8 years ago
Chrome's (5.375 beta) default is yes, Opera's (10.54) is no, but it still allows scrolling.

So it might be worth reconsidering the Firefox default for compatibility reasons.

Updated

8 years ago
Version: 2.0 Branch → Trunk
IE10 (beta) defaults to scrollbars=no, does not allow scroll by mouse wheel or
kbd UP/DOWN, but it does scroll when click-dragging to select text.
status-firefox20: --- → affected
Still exists on 26. Scroll when click dragging doesn't work either.
Status: UNCONFIRMED → NEW
Ever confirmed: true
You need to log in before you can comment on or make changes to this bug.