IMAP connection hangs with too many "UID fetch 53244 (UID RFC822.SIZE BODY.PEEK[])" requests

VERIFIED DUPLICATE of bug 92111

Status

Thunderbird
General
--
critical
VERIFIED DUPLICATE of bug 92111
11 years ago
8 years ago

People

(Reporter: Michael Hart, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

4.35 KB, application/octet-stream
Details
(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.5) Gecko/20070718 Fedora/2.0.0.5-1.fc7 Firefox/2.0.0.5
Build Identifier: "2.0.0.7pre (20070926)", "2.0.0.6", and others

I'm running Thunderbird with one IMAP account against an Exchange server (exchange.foo.bar in the log). I've seen this with at least 2.0.0.4, up to 2.0.0.8.

After some period of time, between five minutes and several hours, Thunderbird will stop loading new messages. Any messages that are marked as new but have never been read cannot be viewed. Only a restart will fix it.

Both the attached log and a wireshark trace shows that Thunderbird is doing up to 700 "UID fetch 53244 (UID RFC822.SIZE BODY.PEEK[])" per second. There seems to be no usage pattern that triggers this behavior, although it does seem to happen after a period of idle time, where the idle time could be as short as one minute.

Reproducible: Always

Steps to Reproduce:
1. 
2.
3.



I'm running Thunderbird on Fedora 7. A colleague is running it on Ubuntu against a similar Exchange server (same company, different server) and is seeing similar behavior.

Also note that Thunderbird is not the only client accessing the account, as there is a BlackBerry server that is also manipulating the email (when I use my BlackBerry, it talks to the BlackBerry server which in turn talks to Exchange). However there is no pattern, this behavior occurs when I don't touch my BlackBerry as well.
(Reporter)

Comment 1

11 years ago
Created attachment 286143 [details]
IMAP log.

IMAP log when Thunderbird hung.

Comment 2

10 years ago
Which version of exchange server 2000/2003/2007? Check also if latest version of Service pack applied or not. Sounds like bug IMAP implementation of exchange server.
Also try latest TRUNK build of TB and see if it happens for you again.

Comment 3

10 years ago
If you are running exchange 2000 here is link for ya
http://support.microsoft.com/kb/320432/en-us
Nikolay: not sure if that URL is relevant; he doesn't say he's using SSL. In fact he can't be, if he's sniffing the traffic using Wireshark.

Michael: are you able to answer Nikolay's question? 

An engineer should look at this log. Confirming.

Gerv
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

10 years ago
I tried many versions of Thunderbird including several 2.0 trunk builds, but all behaved the same way.

I don't know what version of Exchange we were running, and our IT dept. isn't very helpful in that regard. However we were not using SSL. It would not surprise me at all if this was an Exchange IMAP problem (it's buggy at best), but again no control over that bit.

I'm unfortunately not able to comment any further, as we've all moved to running Mac's now, and I'm using Entourage as my main mail client (sorry, need Calendar integration...). I no longer have a Linux system that is capable of running Thunderbird. All I can say is that this was reproducible and happened with at least 3 different people in my department.

cheers
mike
(In reply to comment #0)
> an Exchange server 
> "UID fetch 53244 (UID RFC822.SIZE BODY.PEEK[])"

Problem of Bug 92111? (MS Exchange lies about RFC822.SIZE)

Comment 7

10 years ago
agree on dup 92111

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 92111
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.