Last Comment Bug 401272 - Help support a better install experience for Thunderbird and Sunbird
: Help support a better install experience for Thunderbird and Sunbird
Status: RESOLVED FIXED
:
Product: addons.mozilla.org Graveyard
Classification: Graveyard
Component: Public Pages (show other bugs)
: 3.0
: All All
: -- normal
: 3.2
Assigned To: Fred Wenzel [:wenzel]
:
:
Mentors:
: 261628 365550 (view as bug list)
Depends on:
Blocks: 418082 418061
  Show dependency treegraph
 
Reported: 2007-10-26 10:37 PDT by Basil Hashem [:baz]
Modified: 2016-02-04 14:51 PST (History)
11 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Force add-ons for non-browser apps to be downloaded by the browser (9.32 KB, patch)
2008-01-10 04:14 PST, Fred Wenzel [:wenzel]
wclouser: review+
Details | Diff | Splinter Review

Description Basil Hashem [:baz] 2007-10-26 10:37:05 PDT
1. Need to change the "Install Now" button to say "Download"
2. Change the MIME Type/content disposition/Filename headers so that Firefox doesn't attempt to install Thunderbird add-ons but allows users to save them to local disk
Comment 1 David Ascher (:davida) 2007-10-26 10:40:12 PDT
Note that this applies to Thunderbird & Sunbird-only extensions.  (and Lightning extensions if there are any)
Comment 2 Fred Wenzel [:wenzel] 2007-10-26 10:45:59 PDT
(In reply to comment #0)
> 2. Change the MIME Type/content disposition/Filename headers so that Firefox
> doesn't attempt to install Thunderbird add-ons but allows users to save them to
> local disk

This may not be possible for the downloads served from releases.m.o mirrors (i.e. all public add-ons). Since the file extension is the same, I am not sure if we can make the mirrors serve these files as octet-stream rather than xpinstall.
Comment 3 Michael Morgan [:morgamic] 2007-11-30 11:54:55 PST
What if we channeled non-Firefox downloads to the downloads controller by default?  Then we would have control over content-disposition.  Will take a look at this.
Comment 4 David Ascher (:davida) 2007-11-30 12:02:39 PST
I'm not sure what the last comment implies, but I want to make sure that people know that Seamonkey should probably be treated like Firefox.  I'm not sure how non-gecko browsers should be treated.
Comment 5 Michael Morgan [:morgamic] 2008-01-09 10:38:44 PST
Fred, make it so they are downloaded as attachemnts and the text changes to 'download'.  Give it a shot and let me know if you have questions.
Comment 6 Fred Wenzel [:wenzel] 2008-01-10 02:05:20 PST
*** Bug 365550 has been marked as a duplicate of this bug. ***
Comment 7 Fred Wenzel [:wenzel] 2008-01-10 04:14:21 PST
Created attachment 296312 [details] [diff] [review]
Force add-ons for non-browser apps to be downloaded by the browser

This patch changes the wording for non-browser apps and serves their downloads from the app cluster, marked as an attachment, so the browser does not try to install the file.

Wil, do you mind reviewing this? Please note that you have to compile your en-US messages.mo file after applying the patch, to see the strings.
Comment 8 Fred Wenzel [:wenzel] 2008-01-10 04:21:01 PST
*** Bug 261628 has been marked as a duplicate of this bug. ***
Comment 9 Philip Chee 2008-01-10 06:05:33 PST
I don't have enough context to understand this patch, so the question is how would this handle my extension (Console²) that is compatible with all of Firefox, SeaMonkey, Thunderbird, and Sunbird? Would it force Firefox to download Console² since it's marked Thunderbird compatible?
Comment 10 Fred Wenzel [:wenzel] 2008-01-10 07:31:04 PST
(In reply to comment #9)
> I don't have enough context to understand this patch, so the question is how
> would this handle my extension (Console²) that is compatible with all of
> Firefox, SeaMonkey, Thunderbird, and Sunbird? Would it force Firefox to
> download Console² since it's marked Thunderbird compatible?

Only if the download button is clicked on the thunderbird sub-page (i.e. when the URL has thunderbird in it).
Comment 11 Fred Wenzel [:wenzel] 2008-01-12 09:54:02 PST
Alright, this was committed to the trunk, r9576. I have merged the l10n changes into the other locales in r9578. Marking this fixed, push-needed. Thanks, everybody.
Comment 12 Justin Scott [:fligtar] 2008-02-14 16:34:42 PST
This is live.
Comment 13 Steffen Wilberg 2008-02-15 00:35:09 PST
The how-to-install-in-thunderbird box needs to be changed accordingly.
It still says:
"1. Right-click the link below and choose "Save Link As..." to download and save the file to your hard disk."

It should read:
"1. Click the link below and choose "Save File" to download and save the file to your hard disk."

(Another question is whether Firefox could save the file by default without breaking xpi install in Firefox itself, even on third-party sites and/or with javascript disabled.)
Comment 14 Philip Chee 2008-02-15 02:35:26 PST
> It should read:
> "1. Click the link below and choose "Save File" to download and save the file
> to your hard disk."

In SeaMonkey it says "Save Link Target As..." so you are both wrong.
Comment 15 Philip Chee 2008-02-15 02:37:09 PST
> (Another question is whether Firefox could save the file by default without
> breaking xpi install in Firefox itself, even on third-party sites and/or with
> javascript disabled.)

Yes you could set the mime type in the HTTP headers to content disposition attachment but that is in another bug.
Comment 16 Fred Wenzel [:wenzel] 2008-02-15 03:10:30 PST
(In reply to comment #15)
> > (Another question is whether Firefox could save the file by default without
> > breaking xpi install in Firefox itself, even on third-party sites and/or with
> > javascript disabled.)
> 
> Yes you could set the mime type in the HTTP headers to content disposition
> attachment but that is in another bug.
> 

For non-browser apps, this is what happens.
Comment 17 Magnus Melin 2008-02-16 06:28:14 PST
Only, content-disposition is not currently working in mozilla browsers. (Bug 299372.)
Comment 18 Philip Chee 2008-02-16 07:03:32 PST
> Only, content-disposition is not currently working in mozilla browsers. (Bug
> 299372.)

How does this affect Comment 15 ?
Comment 19 Magnus Melin 2008-02-16 07:10:47 PST
It makes firefox always install no matter what content disposition you use atm - hopefully it will get fixed for 3 though.
Comment 20 Steffen Wilberg 2008-02-17 03:26:05 PST
(In reply to comment #14)
> > It should read:
> > "1. Click the link below and choose "Save File" to download and save the 
> > file to your hard disk."
> 
> In SeaMonkey it says "Save Link Target As..." so you are both wrong.
No. The message displayed on e.g. https://addons.mozilla.org/en-US/thunderbird it Thunderbird-specific.
And the message and this bug don't apply to Seamonkey at all, since Seamonkey pages (https://addons.mozilla.org/en-US/seamonkey) show the "Install Now" link, whereas Thunderbird and Sunbird pages show "Download Now" because you need to download in the browser of your choice and then install in Thunderbird/Sunbird.

(In reply to comment #15)
> > (Another question is whether Firefox could save the file by default without
> > breaking xpi install in Firefox itself, even on third-party sites and/or 
> > with javascript disabled.)
> 
> Yes you could set the mime type in the HTTP headers to content disposition
> attachment but that is in another bug.
*This bug* made amo send content-disposition:attachment on Thunderbird/Sunbird pages. And bug 299372 doesn't affect amo since the link contains the filename of the xpi (instead of e.g. attachment.cgi like bugzilla).

(In reply to comment #19)
> It makes firefox always install no matter what content disposition you use atm
> - hopefully it will get fixed for 3 though.
I don't think this happens by default. I get the dialog saying "What should Minefield do with this file? Open with/Save File? Do this automatically for files like this from now on?" Maybe you selected the "do this automatically" checkbox in the past and now have an "XPInstall" entry in Options -> Applications.

And that's what I meant to suggest in comment 13: Firefox shouldn't ask but save xpi files when sent with content-disposition:attachment, as if I had chosen "Save File" and selected the "do this automatically checkbox" already.
Comment 21 Philip Chee 2008-02-17 03:40:45 PST
> And the message and this bug don't apply to Seamonkey at all, since Seamonkey
> pages (https://addons.mozilla.org/en-US/seamonkey) show the "Install Now" link,
> whereas Thunderbird and Sunbird pages show "Download Now" because you need to
> download in the browser of your choice and then install in Thunderbird/Sunbird.

But SeaMonkey /is/ the browser of my choice. Duh.
Comment 22 Steffen Wilberg 2008-02-22 01:56:09 PST
The message is not displayed for Seamonkey addons, only for Thunderbird addons. Are you using Seamonkey *and* Thunderbird?
Comment 23 Philip Chee 2008-02-22 02:51:40 PST
> The message is not displayed for Seamonkey addons, only for Thunderbird addons.
> Are you using Seamonkey *and* Thunderbird?

Yes to both (that is I use SeaMonkey to download Thunderbird specific extensions).

Note You need to log in before you can comment on or make changes to this bug.