Should <select> grow on change to longer option?

RESOLVED DUPLICATE of bug 429302

Status

()

RESOLVED DUPLICATE of bug 429302
11 years ago
10 years ago

People

(Reporter: developer, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8

*{padding:0}

The above css declaration causes drop-down arrow on <select> to cover last letter on longest length option




Reproducible: Always

Comment 1

10 years ago
In Firefox 2, if I select the longest option, it indeed gets truncated. I guess this won't be fixed.

However, Firefox 3 and trunk show a strange behaviour instead: When I go through all options available, the select element's width grows when I choose the longest option.

This is different from other engines where the select element always takes as much space as needed to always make all options visible.
Status: UNCONFIRMED → NEW
Component: General → Layout: Form Controls
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → layout.form-controls
Summary: <select> tag truncates options with 0-padding css → Should <select> grow on change to longer option?
Version: unspecified → Trunk
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429302
You need to log in before you can comment on or make changes to this bug.