Closed Bug 401389 Opened 15 years ago Closed 15 years ago

[Proto] Task dialog shows dots beside checkbox when start or due date checkbox given focus

Categories

(Calendar :: Tasks, defect)

x86
Windows XP
defect
Not set
trivial

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ednotover, Assigned: mschroeder)

Details

Attachments

(4 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8pre) Gecko/20071023 Sunbird/0.7

I believe the issue may be that the checkbox has no text associated with it, and that the focus indicator is to show checkbox text surrounded by a dotted line.  If so, these dots are nothing more than a degenerate dotted line box (around no text).  I'm pretty certain that's the issue, since the dots disappear once I move focus away from the checkbox.

In a moment, I will attach pictures for (hopeful) clarification - I think they'll show the issue a lot better than I can try to explain it.

Reproducible: Always

Steps to Reproduce:
1. Open the task dialog (start a new task, or edit an existing one)
2. Move focus to one of the date checkboxes - dots appear.
3. Move focus away - dots disappear.


Expected Results:  
I don't know what to recommend here, since I'm guessing it's an OS issue.  If it's possible to have the dotted line around the due date and time fields, perhaps that would be clearer.
Attached image Focus on due date
Attached image Focus on start date
See Bug 259478 for a fix in the old dialog.
Confirmed with Tb 2.0.0.7pre + Lightning 0.8pre (2007110703) on WinXP.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Task dialog shows dots beside checkbox when start or due date checkbox given focus → [Proto] Task dialog shows dots beside checkbox when start or due date checkbox given focus
Assignee: nobody → mschroeder
Status: NEW → ASSIGNED
Attached patch Patch v1Splinter Review
Ported the fix from bug 259478.
Attachment #287882 - Flags: review?(michael.buettner)
Comment on attachment 287882 [details] [diff] [review]
Patch v1

Thanks for the patch -> r=mickey.
Attachment #287882 - Flags: review?(michael.buettner) → review+
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.8
Verified with Lt 2007120303 and Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11pre) Gecko/20071203 Calendar/0.8pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.