Closed Bug 401403 Opened 15 years ago Closed 15 years ago

Prints before custom date range

Categories

(Calendar :: Printing, defect)

x86
Windows Vista
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 354198

People

(Reporter: John, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
Build Identifier: Sunbird version 0.7

In printing month grid with custom start date, the date it starts with is one day sooner than From date.

Reproducible: Always

Steps to Reproduce:
1.Ctrl/P (Print)
2.Layout: select Monthly Grid
3.Select custom date range 11/1/2007 to 11/30/2007
Actual Results:  
Prints the contents of October 31.
(Also displays on the Print Preview.)
Does not print contents of October 29 or 30.
(Results are the same using October 1 as FROM date.)

Expected Results:  
The contents of October 31 should be blank.

When any day other than the first day of the month is used for the FROM date, results are correct.  The previous day (out of selected range) is only collected when the first day of the month is selected.
Does this happens only for all day events (see Bug 354198) or for non all day events too?
(In reply to comment #1)
> Does this happens only for all day events (see Bug 354198) or for non all day
> events too?
> 

Reply:  This happens on all-day events only.  Good call.
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 354198
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.