Failure to open Add ons Manager in debug build

VERIFIED DUPLICATE of bug 401612

Status

()

--
blocker
VERIFIED DUPLICATE of bug 401612
11 years ago
11 years ago

People

(Reporter: bc, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Attempting to open the Add ons Manager fails in Linux trunk debug builds but succeeds on Linux opt and Windows/Mac opt and debug builds.

Steps to reproduce:

1. Click Tools.
2. Click Add-ons.

Expected Result:

Add-ons Manager opens

Actual Result:

Add-ons Manager does not open and the following appears in the error console:

Error: uncaught exception: [Exception... "Component returned failure code: 0xbf972704 [nsIDOMJSWindow.openDialog]"  nsresult: "0xbf972704 (<unknown>)"  location: "JS frame :: chrome://browser/content/browser.js :: BrowserOpenAddonsMgr :: line 4702"  data: no]

I'm not sure when this regressed but I could reproduce it with this morning's debug builds evening after clobbering/rebuilding and rm -fR the objdir and rebuilding.
(Reporter)

Comment 1

11 years ago
hmmm, maybe more general than just the addons mgr since Help->About Minefield is giving 

Error: uncaught exception: [Exception... "Component returned failure code: 0xbf972914 [nsIDOMJSWindow.openDialog]"  nsresult: "0xbf972914 (<unknown>)"  location: "JS frame :: chrome://browser/content/utilityOverlay.js :: openAboutDialog :: line 318"  data: no]
Component: Extension/Theme Manager → General
QA Contact: extension.manager → general
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 401612
(Reporter)

Comment 3

11 years ago
how did a f'ing miss that one! doh.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.