turn StrictDTD on by default for nsbeta2

VERIFIED FIXED

Status

()

defect
P3
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: rickg, Assigned: rickg)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+][6/15] fix in hand, )

Assignee

Description

19 years ago
We've made good progress on the StrictDTD handling system. After discussions 
with hamerly, I'm convinced that it would be useful to get beta2 feedback on 
this code. The code is controlled by an environment setting (non-mac) which I 
propose enabling by default. If during beta testing (prior to beta2 release) we 
determine that it's problematic, we'll return the default setting to OFF.
Assignee

Comment 1

19 years ago
Requestion nsbeta2 checkin.
Status: NEW → ASSIGNED
Keywords: nsbeta2

Comment 2

19 years ago
Putting on [nsbeta2+][5/16] radar.
Whiteboard: [nsbeta2+][5/16]
Assignee

Comment 3

19 years ago
*** Bug 34688 has been marked as a duplicate of this bug. ***

Comment 4

19 years ago
Putting on [NEED INFO] radar.  PDT requests ekrockinput at tomorrow 4pm mtg on 
this issue.
Whiteboard: [nsbeta2+][5/16] → [NEED INFO]
Assignee

Comment 5

19 years ago
What happened? This was on tap to land when the tree opened for new feature 
work, and now it's [need info]?  Grrr.

If this code doesn't land, we CANNOT claim to support XHTML, since it can be 
rendered as BOTH html and xml. StrictDTD is the only way to do that, in addition 
to providing support for strict-mode HTML4. 

I don't know whether Ekrock is aware of these issues. 
Recommend nsbeta2+. Essential for being able to state strict compliance with 
HTML 4.0 spec as well as for enabling interoperability of XML and HTML 
for content/web app platform through XML Namespaces and XHTML. Also low risk as 
strict DTD is only invoked when DTD at top of HTML file requests it.
Whiteboard: [NEED INFO]
Assignee

Comment 7

19 years ago
Ekrock is my hero. :)
Assignee

Comment 8

19 years ago
The PDT has agreed to give this beta2+ status until 6/15.
Whiteboard: nsbeta2+

Comment 9

19 years ago
Adding [6/15] indication.
Whiteboard: nsbeta2+ → [nsbeta2+][6/15]
Assignee

Updated

19 years ago
Whiteboard: [nsbeta2+][6/15] → [nsbeta2+][6/15] fix in hand
*** Bug 40893 has been marked as a duplicate of this bug. ***
Assignee

Comment 11

19 years ago
This was landed on Friday; strict and transitional 4.0 DTD's are now active. To 
disable them, you can set MOZ_DISABLE_STRICT in your environment.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED

Comment 12

19 years ago
Code fix
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.