always crash in this URL

VERIFIED FIXED

Status

()

Core
HTML: Parser
P3
critical
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: m_kato, Assigned: ruslan)

Tracking

({crash, topcrash})

Trunk
x86
All
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+], URL)

Attachments

(1 attachment)

ENVIRONMENT
===========
Mozilla 2000-05-20-15

REPRO STEP
==========
browse http://www.wakaba.toyonaka.osaka.jp/~ikemo/

RESULT
======
crask in msvcrt!memcpy

STACK TRACE (my build of 2000-05-29)
====================================
000000000012f840  0000000010049eaf  MSVCRTD!memcpy+0x33(0x040897F0, 0x00000000, 
0x00000440) (No FPO)
000000000012f854  0000000002d92a4c  
XPCOM!nsByteArrayInputStream::Read+0xbf(0x047B6990, 0x040897F0, 0x00000440, 
0x0012F920) (No FPO)
000000000012f934  0000000002681e4a  
GKPARSER!nsParser::OnDataAvailable+0x21d(0x03898838, 0x03CA1330, 0x00000000, 
0x047B6990, 0x00000000, 0x00000440) (No FPO)
000000000012f95c  000000000230e27a  
URILDR!nsDocumentOpenInfo::OnDataAvailable+0x4a(0x03CA5640, 0x03CA1330, 
0x00000000, 0x047B6990, 0x00000000, 0x00000440) (No FPO)
000000000012f988  00000000022d8de8  
NECKO!nsHTTPFinalListener::OnDataAvailable+0xca(0x03CA6BB0, 0x03CA1330, 
0x00000000, 0x047B6990, 0x00000000, 0x00000440) (No FPO)
000000000012f9e8  000000000230caf4  
NECKO!nsHTTPChunkConv::OnDataAvailable+0x388(0x0407FFA8, 0x03CA1330, 
0x00000000, 0x046DD4DC, 0x00000000, 0x0000000C) (No FPO)
000000000012fbb4  00000000022af7fe  
NECKO!nsHTTPServerListener::OnDataAvailable+0xbe4(0x046DD9B0, 0x04445124, 
0x03CA1330, 0x046DD4DC, 0x0000051A, 0x0000000C) (No FPO)
000000000012fbe0  00000000022aeb91  
NECKO!nsOnDataAvailableEvent::HandleEvent+0xde(0x03E0D3F0) (No FPO)
000000000012fbf8  0000000010067c29  
NECKO!nsStreamListenerEvent::HandlePLEvent+0x41(0x03E0D440) (No FPO)
000000000012fc0c  0000000010067ae7  XPCOM!PL_HandleEvent+0x49(0x03E0D440) (No 
FPO)
000000000012fc20  0000000010068027  
XPCOM!PL_ProcessPendingEvents+0x87(0x015469E0) (No FPO)
000000000012fc30  0000000077e41213  XPCOM!md_EventReceiverProc+0x27(0x008C022C, 
0x0000C152, 0x00000000, 0x015469E0) (No FPO)
000000000012fc4c  0000000003f4cc70  USER32!DispatchMessageWorker+0xa2 (FPO: 
[ebp 008c022c] [2,2,4])
00000000008c022c  0000000000000000  EDITOR!EditAggregateTxn::Do+0x9c (No FO)
Sorry, platform is Windows NT 4.0 SP6a JPN.  Other platform don't test.

Comment 2

18 years ago
crashes for me also on 2000052808 winme, in mscvrt as you said.  stack trace 
already provided, but talkback id is TB11343349M

trying networking
Assignee: asadotzler → gagan
Severity: normal → critical
Status: UNCONFIRMED → NEW
Component: Browser-General → Networking
Ever confirmed: true
Keywords: crash
QA Contact: jelwell → tever

Comment 3

18 years ago
mscvrt = msvcrt in last post

Comment 4

18 years ago
OS=All. Reproduced on PC/Linux with 2000052708. 
This stack trace is quite popular:

#0  0x402af4a7 in memcpy (dstpp=0x86f86f8, srcpp=0x0, len=1088)
#1  0x400aa588 in nsByteArrayInputStream::Read ()  from libxpcom.so
#2  0x40904f1c in InterceptStreamListener::Read () from libnecko.so
#3  0x40ff56f0 in nsParser::OnDataAvailable ()     from libraptorhtmlpars.so
#4  0x409b81d8 in nsDocumentOpenInfo::OnDataAvailable ()

Other bugs where this stack shows up include:
Bug 34491 "http://www.excite.com/" (FIXED long time ago)
Bug 30243 (see Comments From claudius@netscape.com 2000-04-07
11:07)                
Bug 27507 (see Comments From Daniel Bratell 2000-05-07 14:59
           or  Comments From Nisheeth Ranjan 2000-05-09 20:16)
Bug 38158 (see Comments From Nisheeth Ranjan 2000-05-22 23:43)
and a similar one can be found in bug 38352.
OS: Windows NT → All

Comment 5

18 years ago
->parser
Assignee: gagan → rickg
Component: Networking → Parser
QA Contact: tever → janc

Comment 6

18 years ago
Gagan: The parser is calling gecko for data, which is where the crash occurs. 
Did you actually see something specific in the parser? If so, please attach and 
reassign to me.
Assignee: rickg → gagan
No longer crash using 2000060220 nightly build on Windows 2000.
Content is not displayed by default, but it will be fixed as soon as strict DTD 
is enabled.

*** This bug has been marked as a duplicate of 40190 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 8

18 years ago
Reopening. Still crashing on PC/Linux, build 2000060308.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
This bug is 2 issue.

o same bug 40190
o when _buffer is null, it always crashs.
Created attachment 9581 [details] [diff] [review]
a patch of mozilla/xpcom/io for crash

Comment 11

18 years ago
Adding 'patch' keyword, as there is a simple patch to avoid the crash. When 
being ok, shouldn't this checked be in as fast as possible?
Keywords: patch

Comment 12

18 years ago
Get the patch reviewed by either gagan or rick, and approved by waterson or 
brendan, and I'll check it in...
Adding nsbeta2 and topcrash keywords.  This crash is the one that shows up as
"MSVCRT.DLL + 0x11ce" in the talkback data in n.p.m.crash-data (and that's only
the ones on Windows).  Those account for 4 of 229 crash reports on builds since
5-29 (plus any incidents on Linux or Mac, which would show up differently). 
Considering there is an easy fix attached, this should be fixed for beta2.
Keywords: nsbeta2, topcrash

Comment 14

18 years ago
Putting on [nsbeta2+] radar for beta2 fix. 
Whiteboard: [nsbeta2+]

Comment 15

18 years ago
ruslan should review this patch and check it in. 
Assignee: gagan → ruslan
Status: REOPENED → NEW
(Assignee)

Comment 16

18 years ago
I fixed this in a different way earlier. It doesn't crash anymore. It should be 
marked fixed.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 17

18 years ago
Verified
2000-07-12-11-M17 : Linux
2000-07-12-09-M17 : WinNT & Win98
2000-07-12-13-M17 : Mac
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.