[10.5] Thunderbird does not give confirmation that it is the default email client

RESOLVED WORKSFORME

Status

Thunderbird
General
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

10 years ago
Seen while testing BuildID = "2007103105".

STR:
1. Install the Thunderbird candidate in the Applications directory.
2. Make Apple mail the default by adjusting the Pref in Apple mail.
3. Launch Thunderbird (make sure the "Always check" pref is turned on in Thunderbird.
4. Check the appropriate boxes to make Tbird the default.
5. Go into Thunderbird Preferences and click "Check now"

Observe that you do not receive confirmation that "Thunderbird is already set as your default email client." If I check the Apple Mail pref, Thunderbird 2.0.0.9 is listed as the default.

I tested this on Tiger using the Thunderbird branch nightly and I do get the confirmation if I follow roughly the same steps.
(Reporter)

Comment 1

10 years ago
Note that Thunderbird does behave correctly when it is the default, it launches links from Firefox, as does Apple Mail when it is set as the default. What is confusing to the user is there is no confirmation.
Hmm, does Firefox have the same issue? Other than our falling behind on changes, I'd be surprised if we do anything different than Fx to check and alert, and equally surprised if Apple changed the API for mail but not for browser.
(Reporter)

Comment 3

10 years ago
Firefox does not seem to have the same issue on Leopard. With Minefield and Firefox installed, in both instances if I select "Check Now" it gives me the confirmation that Firefox is already set as the default browser. I agree with phil's assessment in Comment 2, I don't understand why it doesn't fail for both products.
Summary: [10.5.] Thunderbird does not give confirmation that it is the default email client → [10.5] Thunderbird does not give confirmation that it is the default email client
This was caused by bug 452890
Blocks: 452890
Keywords: regression
Created attachment 360064 [details] [diff] [review]
patch rev1 - being taken care of in bug 476566

The stringbundle for preferences.properties wasn't added in advanced.xul when the check for defaults was moved to the advanced prefpane.
Assignee: nobody → robert.bugzilla
Status: NEW → ASSIGNED
Attachment #360064 - Flags: review?(clarkbw)
OS: Mac OS X → All
Hardware: x86 → All
Attachment #360064 - Flags: review?(clarkbw) → review?(philringnalda)
Comment on attachment 360064 [details] [diff] [review]
patch rev1 - being taken care of in bug 476566

The dates seem a little off if this was reported in 2007 and bug 452890 had it's patch checked-in a year later.  

Either way I'm glad it's getting fixed.  I've switched review to philor as I only do ui-review since my programming skills are not to be trusted. :)
I should have looked at the dates on the report but only looked at the push log to find what had changed and tracked down the cause from there. :(

Anyways, I did verify this fixes this bug for me.
Filed bug 476566 since this was reported prior to the regression I found and the patch may not fix it for Mac OS X as this bug was reported for.
Assignee: robert.bugzilla → nobody
No longer blocks: 452890
Attachment #360064 - Attachment description: patch rev1 → patch rev1 - being taken care of in bug 476566
Attachment #360064 - Attachment is obsolete: true
Attachment #360064 - Flags: review?(philringnalda)

Comment 9

9 years ago
(In reply to comment #8)
> Filed bug 476566 since this was reported prior to the regression I found and
> the patch may not fix it for Mac OS X as this bug was reported for.

Marcia, Bryan, is this fixed for you on Mac with bug 476566 fixed?
Status: ASSIGNED → NEW

Comment 10

9 years ago
going into TB3, we need closure on this bug, and verification of bug 476566

Has 476566 fixed this problem (comment 0 + comment 1) too?
This WFM on

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b5pre) Gecko/20090505 Lightning/1.0pre Shredder/3.0b3pre
Created attachment 375989 [details]
Image of pop-up after clicking "Check Now"

I'm not sure what is expected, but I don't think what I got was what should be done. :) So I do not believe this is fixed. Also on startup the window position of the "Thunderbird isn't your default..." is up and to the left off the screen, can only see the "Cancel" and "Ok" buttons. Looking at the image I've attached it is the same box as that, and I believe since it doesn't have a title bar for the window that is why it is off screen. I'll attach another image of it for clarity.

I've attached an image of what I get when I click "Check Now". It is very unlike the "Firefox is set as your default browser" that I would expect.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b5pre) Gecko/20090506 Shredder/3.0b3pre
Created attachment 375990 [details]
Window off the screen on "check for default mail app" on startup

NOTE: Password manager is running, don't think that makes a difference though.
Jay: what happens if you check "Feeds" on that dialog, then click OK, then check again?

I believe all three items must be checked for you to get the "Thunderbird is already set as your default mail client" dialog.
Mark: thanks for the clarification, if I check all three I get the expected "already set" message. So, WFM now.
I think with this working for two of us, it can be closed as WFM now.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.