Closed Bug 402450 Opened 12 years ago Closed 9 years ago

Implement inline preview for PDF attachments

Categories

(Thunderbird :: General, enhancement)

All
macOS
enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 457546

People

(Reporter: berriganator, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: Thunderbird 2.0.0.6

A few months ago I switched from Eudora for Mac to Thunderbird. One nice thing about Thunderbird is that it displays HTML messages in a way that Eudora never did. However, there are some things that Eudora did that were quite lovely and SORELY MISSED in Thunderbird.

These include:

1. PDF preview
Many people e-mail PDF invites now, which is rather annoying in and of itself, but it can't be helped. I hate having to save the attachment & open it in an external application. Why not have a little preview within the message where the 1st page of the PDF can be seen? It would make me *so* happy!

2. Attachment handling
It's extremely annoying to have to "detach" attachments individually from a message, and then open with an external application. In Eudora, they were automatically saved to an attachments folder. Not only did this keep my desktop from getting horrifically messy, but it also meant that I could organize my e-mail messages into folders, and at a later date *search through* the attachments folder for a document within the finder. That was fantastic.

Can't wait for these to happen... please? Thanks.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Point 2: bug 9309 (and bug 359319). One issue per bug report please.
As per comment #1, this bug's summary should be changed to "Integrate preview for PDF attachments". Platform should be changed to "All".
(In reply to comment #2)
> As per comment #1, this bug's summary should be changed to "Integrate preview
> for PDF attachments". Platform should be changed to "All".
Hardware: PowerPC → All
Summary: PDF preview & attachment handling → Integrate preview for PDF attachments
Duplicate of this bug: 518557
If/when bug 455917 is fixed, I think all we would have to do is to tell libmime that PDFs are really inline content--which might not be advisable anyways.
We should try to decide on this bug.
I can't see all the details of this yet, but the general idea seems valid since PDFs are really frequent attachments and surely many people would appreciate the preview (which probably also means you can just print out the pdf with the mail).

-> NEW?
Depends on: 455917
Summary: Integrate preview for PDF attachments → Implement inline preview for PDF attachments
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 457546
You need to log in before you can comment on or make changes to this bug.