Closed Bug 402530 Opened 13 years ago Closed 13 years ago

'Show Tasks in Calendar' is checked but no task is visible

Categories

(Calendar :: Lightning Only, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: andreas.treumann, Unassigned)

References

Details

(Keywords: regression)

STEPS TO REPRODUCE:
===================

- install lightning 0.7
- enable 'Calendar/View/Show Tasks in Calendar'
- update with lightning build 2007110503
- restart thunderbird

RESULT:
=======

- After restart the 'Calendar/View/Show Tasks in Calendar' is enabled, but no task is displayed in the calendar view
- a recheck of the 'Show Tasks in Calendar' entry is necessary   

EXPECTED RESULT:
================

- after the update the tasks should be visible without any user action. 

REPRODUCIBLE:
=============

- always
Same should apply to other menu entries / commands that were changed, e.g. Show Workweek only.
I can imaging many people asking about disappeared tasks after updating to 0.8 (like it was with disabled calendars after update 0.5->0.7)

I've noticed something new after update ----> 'show tasks in calendar' is not checked and I can see tasks in calendar. If 'show tasks in calendar' is checked there's no tasks in calendar view.

So setting flags to blocking 0.8?
Flags: wanted-calendar0.8?
Lightning 2007120504
Flags: wanted-calendar0.8? → blocking-calendar0.8?
Summary: Update 0.7 with build 2007110503 -> 'Show Tasks in Calendar' is checked but no task visible → 'Show Tasks in Calendar' is checked but no task is visible
Duplicate of this bug: 411466
Duplicate of this bug: 411466
Maybe this one should go into a specific 'Take-care-of-settings-on-upgrade' bug...

I have noticed all my calendars were disabled (unchecked) after upgrade of 0.5 to 0.8pre!
(In reply to comment #6)
> I have noticed all my calendars were disabled (unchecked)
> after upgrade of 0.5 to 0.8pre!

This is the same known issue from the 0.5 to 0.7 upgrade (Bug 401223).
There is a new  problem:
1)Create a new profile and install Lt 2008012403
2)Import a calendar that contains tasks
3)Check 'Show tasks in calendar'

Result:
Task are not visible. restart is required
Not sure if I need a new bug, or if this is the same, but here is what I've noticed:

If tasks are given a start date, they are shown for that day (talking about calendar view). Given start and stop, task is shown for that duration. If only given a due date, the task is NOT displayed. I've reproduced this over and over in Lightning 0.7. 
@Matt: THat's bug 405459 which got fixed some time ago and will be in 0.8.
(In reply to comment #9)
Display of tasks without due date is handled with Bug 349529 / Bug 339955.
We're not going to block 0.8 for this bug, but we'll of course accept patches.
Flags: blocking-calendar0.8? → blocking-calendar0.8+
Flags: blocking-calendar0.8+ → blocking-calendar0.8-
Regression range:
Works 2007-10-27-03
Fails 2007-10-28-01
Keywords: regression
Caused by checking patch from bug 390508?
This should be fixed with patch from bug 409966
Depends on: 409966
Fixed with patch from bug 409966
Verified with Lt 2008021910/Tb 2.0.0.9
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Target Milestone: --- → 0.8
Version: Trunk → unspecified
Flags: blocking-calendar0.8-
You need to log in before you can comment on or make changes to this bug.