"Workweek days only" option is inversed after update from 0.7

VERIFIED FIXED in 0.8

Status

defect
VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: citrusmoose, Assigned: Fallen)

Tracking

({regression})

Dependency tree / graph
Bug Flags:
blocking-calendar0.8 +

Details

Attachments

(2 attachments, 2 obsolete attachments)

Reporter

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Lightning build 2007122704

I have Mon-Fri selected as workweek days in Lightning preferences.  When I select Week, Multiweek, or Month views when "Workweek days only" is unchecked, I only see workdays (Mon-Fri).  If I then select "Workweek days only", all days appear.  I can then deselect the option again, and it will show the opposite of what it's suppose to show.

Reproducible: Always

Steps to Reproduce:
1. Startup Thunderbird
2. Switch to the calendar view
3. Notice the state of the option "Workweek days only" under View > Current View, and compare to the days visible in the Week, Multiweek, or Month views to your current workweek days preference.
4. Toggle the state of the "Workweek days only" option, and repeat step 3.
Actual Results:  
The days visible in the Week, Multiweek, and Month views are opposite of what is expected based on the toggled state of the "Workweek days only" option.

Expected Results:  
The visible days in the calendar pane for Week, Multiweek, and Month views should match the current state of the "Workweek days only" option.

This is probably something that occurred after installing a newer build where something changed in the workweek days logic.  Nevertheless, I'm thinking instead of just toggling the days, actually make a check to that the state of the option actually matches what is displayed.  If it's not acceptable to do this on on every toggle,  it should at least be done at startup.
Reporter

Comment 1

12 years ago
This is a screenshot of the problem.  As you can see the "Workweek days only" option is not selected, yet the view is missing Saturday and Sunday.

Comment 2

12 years ago
I can confirm that something is wrong with "Workweek days only" option:
1)Install Lightning 0.7
2)Set "Workweek days only"
3)Install Lightning 0.8pre 2008012609 and restart
Result:
1)"Workweek days only" option doesn't work at all. Enabling/Disabling does nothing
Reporter

Comment 3

12 years ago
It appears that this is somewhat the case for me too, now.  The option is still inversed, but toggling the option doesn't work dynamically anymore.  It only works after restarting Thunderbird.

Comment 4

12 years ago
Updating Lightning 0.7 to lightning 2007122704 inverses the option. But updating 0.7 to 2008012609 build breaks the option. Changing summary and confirming. To reproduce it see my last comment
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-calendar0.8?
Summary: "Workweek days only" option has become inversed → "Workweek days only" option doesn't work after update from 0.7

Comment 5

12 years ago
And again the option is inversed. Checked with Lightning 2008012900
Summary: "Workweek days only" option doesn't work after update from 0.7 → "Workweek days only" option is inversed after update from 0.7

Comment 6

12 years ago
'Show tasks in calendar' option is also reversed
Reporter

Comment 7

12 years ago
Yep, both are inversed for me again.

Comment 8

12 years ago
This definitely stinks, but we're not going to hold 0.8 for this at this late stage.  We should look and see what relnote we can make of this with a workaround and explanation for people.
Flags: blocking-calendar0.8? → blocking-calendar0.8-
Keywords: relnote

Comment 9

12 years ago
(In reply to comment #8)
> we're not going to hold 0.8 for this at this late
> stage. 

IMO it's a bad decision. People will keep asking about the bug and they will keep asking about disappearing tasks (Bug 402530)

Comment 10

12 years ago
Regression range:
Works 2007-10-27-03
Fails 2007-10-28-01
Keywords: regression

Comment 11

12 years ago
Caused by checking patch from bug 390508?
I can confirm this error (for 'workweek days only' and 'tasks in view') during testing the update from Lightning 0.7 (2007102304) to Lightning 0.8pre (2008021421) on Windows.

If I remember the changes correctly the current commands just toggle the corresponding option (workweek days only and task in view). But the command doesn't bother if the corresponding menu entry is checked or not.

The only workaround might be to reset the entire Thunderbird UI by removing the localstore.rdf file from the profile.
I'll try to find a solution for 0.8, if others find out how first, please take over! I agree this needs to be taken care of, even for 0.8 and this late in the game.
Assignee: nobody → philipp
Flags: blocking-calendar0.8- → blocking-calendar0.8?
Posted patch Reset workday/task options (obsolete) β€” β€” Splinter Review
As a solution, I changed the id of the corresponding menuitems. This removes persistance and lets the command kick in.

The downside is that the option value is not remembered between 0.7 and 0.8, which means you have to go back in the menu and set the option again if you are so inclined. I think this is minor though and since we are still at 0.x I don't think we should add extra migration code for things like this.

Requesting review from anyone who is available :)
Attachment #303872 - Flags: review?
Status: NEW → ASSIGNED
Flags: blocking-calendar0.8? → blocking-calendar0.8+
Keywords: relnote
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → 0.8
Posted patch Reset workday/task options -v2 (obsolete) β€” β€” Splinter Review
Takes care of persistance correctly.

Since the command is observed, the checked state of the command is used for the menuitem.
Attachment #303872 - Attachment is obsolete: true
Attachment #303874 - Flags: review?
Attachment #303872 - Flags: review?
As mvl suggested, to make the views more robust, set the new value instead of toggling it.
Attachment #303874 - Attachment is obsolete: true
Attachment #303875 - Flags: review?
Attachment #303874 - Flags: review?

Updated

12 years ago
Blocks: 402530
Attachment #303875 - Flags: review? → review?(Berend.Cornelius)

Comment 17

12 years ago
Comment on attachment 303875 [details] [diff] [review]
Reset workday/task options -v2b

r=berend. Patch works good and is a smarter solution than before where the state was toggled "blindly" without any control if it is synchronous to the displayed view.
Attachment #303875 - Flags: review?(Berend.Cornelius) → review+
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED

Comment 19

12 years ago
Verified with Lt 2008021910/Tb 2.0.0.9
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.