Last Comment Bug 402964 - Import Safari bookmarks shows up in Bookmarks Toolbar
: Import Safari bookmarks shows up in Bookmarks Toolbar
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Migration (show other bugs)
: unspecified
: PowerPC Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Matthew N. [:MattN] (PM me if requests are blocking you)
Mentors:
: 400193 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-07 17:12 PST by Tony Chung [:tchung]
Modified: 2012-04-15 06:43 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Tony Chung [:tchung] 2007-11-07 17:12:28 PST
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b1) Gecko/2007110618 Firefox/3.0b1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b1) Gecko/2007110618 Firefox/3.0b1

Import Safari bookmarks shows up in Bookmarks Toolbar and Bookmarks folder.   I would think it shouldnt go to bookmarks toolbar.

Importing data from other browsers like Netscape and IE correctly creates a Folder in the Bookmarks dropdown, but not in the bookmarks toolbar.

Reproducible: Always

Steps to Reproduce:
1. Build data in safari
2. install Fx3 beta 1
3. open a clean profile, and file > Import 
4. Choose Safari
5. Verify bookmarks from safari show up on Firefox Bookmarks Toolbar
Comment 1 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2011-12-20 02:32:27 PST
Tony, do you know what's the exact behavior of each migrator about this? The safari migrator was written "by design" (I'm not saying it's good, just that it's not a mistake). I think the new Chrome migrator creates two "From Chrome" folders, one in the toolbar and one in the menu
Comment 2 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2012-04-15 06:41:30 PDT
The new migrator (bug 710259) creates a "From Safari" folder in the bookmarks toolbar folder for these items (when migration is done from the Places organizer).
Comment 3 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2012-04-15 06:43:38 PDT
*** Bug 400193 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.