Last Comment Bug 403059 - Dropdown list for "File Selected Message" is double spaced; arrows are missing.
: Dropdown list for "File Selected Message" is double spaced; arrows are missing.
Status: RESOLVED FIXED
: fixed1.8.1.15, regression
Product: SeaMonkey
Classification: Client Software
Component: MailNews: Message Display (show other bugs)
: 1.8 Branch
: x86 OS/2
: -- normal (vote)
: ---
Assigned To: Walter Meinl
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-08 11:34 PST by James J. Weinkam
Modified: 2008-03-27 14:21 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
add moz-region:auto solves the problem (524 bytes, patch)
2008-03-26 16:30 PDT, Walter Meinl
mozilla: review+
Details | Diff | Splinter Review

Description James J. Weinkam 2007-11-08 11:34:55 PST
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.8.1.9) Gecko/20071103 SeaMonkey/1.1.6
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.8.1.9) Gecko/20071103 SeaMonkey/1.1.6

When browsing mail or a news group, the dropdown list that appears after clicking file and selecting the desired account

(a) is double spaced, reducing the number of folders fisible at one time;

(b) is missing the up and down arrows;

(c) scrolls as soon as the mouse pointer is over the area where the arrow belongs rather than requiring a mouse button to be down, making scrolling difficult to control;

(d) displays the list from the top to the bottom of the screen rather than avoiding the ecenter; if the scroll control gets under the ecenter there doesn't seem to be a way to get it on top again other than starting over.

This is a regression from the last version of Mozilla.

In addition to fixing this would it be possible to display the list as multiple columns if it will fit on the screen.

Reproducible: Always

Steps to Reproduce:
1. Select a mail or news group message
2. Click File Tool
3. Select account with more folders than will fit in one column
Actual Results:  
As described above

Expected Results:  
Folder list should be single spaced.  Arrows should appear in scroll controls. Scrolling should not occur unless mouse button is down.  Scroll controls should avoid ecenter. If possible, entire list should be displayed in multiple columns.
Comment 1 Peter Weilbacher 2007-11-10 08:19:15 PST
James, I didn't really understand what I should do to reproduce the problem. The only file to click is the File menu and that doesn't relate to a dropdown with the accounts... Can you please clarify? Perhaps even make a screenshot and attach it here?
Comment 2 James J. Weinkam 2007-11-10 17:36:49 PST
In the Mail and Newsgroups window, immediately below the menu bar that contains:
File Edit View Go Bookmarks Tools Window Help
is a row of icons with labels:
GerMsg Compose | Reply ReplyAll Forward | File Next Junk Delete Print Help

That's the File I'm talking about; it allows the user to choose where to file the selected message.  I'm not sure what these objects are called (Tools?)
Comment 3 Peter Weilbacher 2007-11-10 18:01:40 PST
Ah, OK. The File button in the mail toolbar. I had it switched off in my setup.

Yes, that is indeed heavily broken. As far as I can tell it has been this way for all SeaMonkey 1.1.x releases, but it was working correctly for SeaMonkey 1.0.x. I suspect that it has to do with my efforts to improve the default theme, so that SeaMonkey looks more OS/2-like.
Comment 4 Peter Weilbacher 2007-12-09 16:24:04 PST
OK, I took a look at it today. Unfortunately, the only thing that I found out was that using old Windows version of menu.css instead of the OS/2 version gets it working again (of course it has other problems).
I couldn't find out exactly what triggers this problem. DOM Inspector shows the properties of the menupopup to be almost identical, and I already explored the differences...
Comment 5 Walter Meinl 2008-03-26 16:30:21 PDT
Created attachment 311906 [details] [diff] [review]
add moz-region:auto solves the problem

I've copied the two lines of the toolkit theme. The problem with the file list drop down seems to be that it's an iconic list that is not properly handled by the seamonkey menu.css
In fact adding the line   -moz-image-region: auto; would be sufficient (the "list-style-image: none;" line is not needed to solve the problem. Unfortunately I've remembered this bug too late for seamonkey-1.1.9
Comment 6 Peter Weilbacher 2008-03-27 13:12:13 PDT
Comment on attachment 311906 [details] [diff] [review]
add moz-region:auto solves the problem

Yes, this indeed fixes the problem. I don't know why I was so blind not to see it.

Do you agree that we should apply the same fix on trunk, even though it is not necessary? I see that win/menu.css file still has it.
Comment 7 Walter Meinl 2008-03-27 13:29:43 PDT
(In reply to comment #6)
> (From update of attachment 311906 [details] [diff] [review])
> Yes, this indeed fixes the problem. I don't know why I was so blind not to see
> it.
Well, you find so much more important solutions to nearly every problem with mozilla on OS/2 that I sometime wonder how many eyes you have and if you even sleep from time to time 8-)
> 
> Do you agree that we should apply the same fix on trunk, even though it is not
> necessary? I see that win/menu.css file still has it.
> 
I don't mind, go for it. Maybe we need it sometime again and then might have forgotten it....
Comment 8 Peter Weilbacher 2008-03-27 13:42:44 PDT
Ah, that file (and the whole themes/classic branch of the source tree) is unused on trunk by now (see bug 394567 and bug 383909). And I was wondering why the file packaged in classic.jar and the file we are talking about were so different...

So I will just check this into branch (and use in my enhanced builds).
Comment 9 Peter Weilbacher 2008-03-27 14:21:54 PDT
OK, fixed on 1.8 branch.

James, if you want to verify you can get the next usable nightly build from http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/contrib/latest-mozilla1.8/ (so one called seamonkey-1.1.10pre.* with a date of Mar 27th or later).

Note You need to log in before you can comment on or make changes to this bug.