Upgrade NSIS on the 1.8 Win32 tinderboxen to version 2.22

RESOLVED FIXED

Status

Webtools Graveyard
Tinderbox
P2
normal
RESOLVED FIXED
11 years ago
4 years ago

People

(Reporter: rstrong, Assigned: joduinn)

Tracking

({fixed1.8.1.13})

Details

(URL)

To land bug 370571 on the branch NSIS on the MOZILLA_1_8_BRANCH Firefox tinderbox that use NSIS (e.g. qm-pxp02 and pacifica-vm) will need to be upgraded to version 2.22 which is the version currently used on the trunk. Ideally NSIS would be upgraded to version 2.22 on all Win32 MOZILLA_1_8_BRANCH tinderboxen so other apps can also implement bug 370571.
Assignee: nobody → build
Component: Build Config → Tinderbox Configuration
Product: Core → mozilla.org
QA Contact: build-config → ccooper
Version: 1.8 Branch → other
cf confirmed offline that this (NSIS v2.22) is the same version as is already on trunk, so is for 1.8 branch only. 

For 1.8 branch, this would mean updating the following machines:
qm-pxp02
pacifica-vm
staging-pacifica-vm
production-pacifica-vm

Updating summary.
Summary: Upgrade NSIS on the Win32 tinderboxen to version 2.22 on qm-pxp02 and pacifica-vm → Upgrade NSIS on the 1.8 Win32 tinderboxen to version 2.22
(In reply to comment #1)
> For 1.8 branch, this would mean updating the following machines:
> qm-pxp02
> pacifica-vm
> staging-pacifica-vm
> production-pacifica-vm

Slight correction:

- qm-pxp02, since Talos runs builds but doesn't create them
+ patrocles, for Thunderbird
+ solaria, for Sunbird
No longer blocks: 403552
From IRC, seems there are ANSI and UNICODE versions of NSIS available. Unclear if we should be using only ANSI or only UNICODE. 

Who could best answer this?
The ANSI version should be installed for the branch
No longer blocks: 402848
Priority: -- → P3

Comment 5

11 years ago
So this prevented side-by-side install improvements for 20012 which is a huge bummer.  What can we do to resolve this?
Priority: P3 → P1
Equally bummed. Sorry we missed this, it was unclear it was required for FF2.0.0.12. 

Talked with schrep, and this is not something to respin for, so downgrading to P2. We'll land this as soon as FF2.0.0.12 ships.
Priority: P1 → P2
FF2.0.0.12 just shipped. 

We have time in schedule, so we could land this early next week before TB2.0.0.12 builds. Is that ok, or should we wait until after TB2.0.0.12 ships in order to keep FF2.0.0.12 and TB2.0.0.12 in sync?
Rob, if we were to upgrade the Firefox machines and you land attachment 282816 [details] [diff] [review] (is that the right one?), would there be any impact on Thunderbird or Sunbird from the changes in toolkit/ ? To put it another way, do we need to upgrade all the win32 tinderboxes before the patch can land ?
The patch is ifdef so it won't fail on the non Firefox tinderboxen so it won't affect them.
Does upgrading the tinderboxen also upgrade the release builds? Why is there an effort to modify the shipping toolchain without branch blocking/approved bugs?
(In reply to comment #7)
> FF2.0.0.12 just shipped. 
> 
> We have time in schedule, so we could land this early next week before
> TB2.0.0.12 builds. Is that ok, or should we wait until after TB2.0.0.12 ships
> in order to keep FF2.0.0.12 and TB2.0.0.12 in sync?
Turns out we started the TB2.0.0.12 builds a little earlier, so didnt have time to do the NSIS update beforehand. We dont want to do this *during* the TB2.0.0.12 release, in case we need to respin, so waiting until TB ships next week.

(fixing assignment, as it got accidently trampled over.)
Assignee: build → joduinn
John, did you see comment #9 ? We need to make sure 1.8 drivers like dveditz are happy first, but we could update the Firefox boxes to get things moving, and do Thunderbird after 2.0.0.12 ships.
Yep, dveditz & I exchanged emails offline, and we'll wait for his approval before making these changes. Resetting "wanted 1.8.1.x ?" as I must not have set it correctly earlier this week.

Flags: wanted1.8.1.x?
talked to dveditz offline, and he added "blocking 1.8.1.13" flag, so marking that in order to appear on triage queue.
Flags: blocking1.8.1.13?
Flags: wanted1.8.1.x?
Flags: wanted1.8.1.x+
Flags: blocking1.8.1.13?
Flags: blocking1.8.1.13+
Dan marked this bug as blocking 1.8.1.13 earlier today. Feel free to move forward with upgrading NSIS on the 1.8 Windows tinderboxen.
I know I need to install the ANSI version (from comment#4 ). 

What version of ANSI should I install? The latest available is 2.35.1 - should I use that? Looking on http://www.scratchpaper.com/ and http://sourceforge.net/project/showfiles.php?group_id=22049&package_id=15374, there are lots of previous versions available, so I can install an older version if that is a specific requirement. 

Unless I hear otherwise, I'll start installing 2.35.1 tonight/tomorrow.
Should we be updating NSIS on trunk/1.9 also?
See comment 1
John, version 2.22 per comment #0 and trunk is already using version 2.22 via MozillaBuild. This is to sync the two so they are both using the same version.
(In reply to comment #19)
> John, version 2.22 per comment #0 and trunk is already using version 2.22 via
> MozillaBuild. This is to sync the two so they are both using the same version.
Cool, thanks Rob. 

I was confused earlier today, because I found http://wiki.mozilla.org/ReferencePlatforms/Win32 saying v2.17 was on trunk. However, Ted and Rhelmer confirmed v2.22 is on trunk as part of MozillaBuild1.2, and I've fixed up the doc to match reality. 

I've now updated staging-pacifica-vm with nsis v2.22 in c:\program files\nsis, after first removing the previous nsis (v2.17) from the same location.
pacifica-vm and production pacifica-vm to follow ?
I've also done the same "replace v2.17 with v2.22" on the following machines:

cerberus-vm
pacifica-vm 
(In reply to comment #2)
> (In reply to comment #1)
> > For 1.8 branch, this would mean updating the following machines:
[snip
> + solaria, for Sunbird

ctalbert: who owns solaria? Is this a community machine or MoCo machine? And should NSIS update be updated? 

Comment 24

11 years ago
(In reply to comment #23)
> (In reply to comment #2)
> > (In reply to comment #1)
> > > For 1.8 branch, this would mean updating the following machines:
> [snip
> > + solaria, for Sunbird
> 
> ctalbert: who owns solaria? Is this a community machine or MoCo machine? And
> should NSIS update be updated? 
> 
Solaria is an old Tbox for Sunbird that has been around a long time.  It's not a community machine AFAIK.  It would be great if you would update it for us.

I've CC'd Ause, our calendar build guru in case he has more opinions about it, but he had no strong objections to this when I asked him online.


I've also done the same "replace v2.17 with v2.22" on production-pacifica-vm. 

I was not able to login to patrocles, or solaria, using either VNC or RDP. Can anyone else access these machines or are they down?

The only other non-trunk win32 machines on http://wiki.mozilla.org/Build:Farm were: moz180-win32-tbox, tb180-win32-tbox, which I'm ignoring, because they are due to be powered off anyway with bug#411341.
Status: NEW → ASSIGNED
(In reply to comment #25)
> The only other non-trunk win32 machines on http://wiki.mozilla.org/Build:Farm
> were: moz180-win32-tbox, tb180-win32-tbox, which I'm ignoring, because they are
> due to be powered off anyway with bug#411341.

fwiw, we wouldn't upgrade those machines anyway. This bug is only approved for the 1.8 branch not the 1.8.0 branch. bug 370571 will never land on the 1.8.0 branch.

Comment 27

11 years ago
(In reply to comment #25)
> 
> I was not able to login to patrocles, or solaria, using either VNC or RDP. Can
> anyone else access these machines or are they down?
solaria works fine for me via RDP. what kind of problems did you have?
(In reply to comment #25)
> I've also done the same "replace v2.17 with v2.22" on production-pacifica-vm. 
> 
> I was not able to login to patrocles, or solaria, using either VNC or RDP. Can
> anyone else access these machines or are they down?
> 
> The only other non-trunk win32 machines on http://wiki.mozilla.org/Build:Farm
> were: moz180-win32-tbox, tb180-win32-tbox, which I'm ignoring, because they are
> due to be powered off anyway with bug#411341.
> 

patrocles is on mpt-vpn and you should connect with VNC. I'm guessing solaria is mpt-vpn + RDP. Sounds like you may have had VPN issues.
solaria is in the community build network rather than the MoCo one, so you have to take different steps to reach it.
(In reply to comment #29)
> solaria is in the community build network rather than the MoCo one, so you have
> to take different steps to reach it.
(Thanks nick for walking me through the connect-to-community-machines dance.)

On Solaria, I removed nsis2.17 and installed nsis2.22. Unlike the other machines so far, Solaria has nsis installed in c:\buildtools\nsis, so I installed v2.22 into the same c:\buildtools\nsis directory.
(In reply to comment #28)
> (In reply to comment #25)
> > I was not able to login to patrocles, or solaria, using either VNC or RDP. Can
> > anyone else access these machines or are they down?
> patrocles is on mpt-vpn and you should connect with VNC. I'm guessing solaria
> is mpt-vpn + RDP. Sounds like you may have had VPN issues.

(Actually, turns out my VPN was fine. Does need VNC to connect... and is running *really* slowly. Like "attempt to connect, give up, literally go make coffee, come back and be surprised"!).

I've now installed nsis2.22 in c:\program files\nsis after first removing the previous nsis (v2.18) from the same location.
From looking through the bug comments above, here is the list of machines that have been updated to use NSIS 2.22:

pacifica-vm
staging-pacifica-vm
production-pacifica-vm
cerberus-vm
patrocles, for Thunderbird
solaria, for Sunbird

Note: bl-bldxp01 is a 1.8 machine, but I did not update it as it is being powered off in bug#413695.

Thats all the win32 machines for 1.8 listed on http://wiki.mozilla.org/Build:Farm, so closing.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
For QA: There's not really a way to test this, except to ensure that our installers still work properly (nightlies and releases).
Keywords: fixed1.8.1.13

Updated

7 years ago
Component: Tinderbox Configuration → Tinderbox
Flags: wanted1.8.1.x+
Flags: blocking1.8.1.13+
Product: mozilla.org → Webtools
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.