Tabs opened from a page should spawn right after the current tab

RESOLVED DUPLICATE of bug 465673

Status

()

enhancement
RESOLVED DUPLICATE of bug 465673
12 years ago
10 years ago

People

(Reporter: virgile.bello, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9

It's often very tedious to navigate with lot of tabs open. Suppose you go to the first tab, middle click to follow a link in another tab and it spawns at the end of the tabs list (probably hidden). I think it should be more appropriate to spawn tabs opened from another tab just after it.
That way, even shortcut such as ctrl+page down could be very efficient.
It's probably an easy to fix problem concerning a big hassle for the navigation and user experience (IMHO).

Reproducible: Always

Steps to Reproduce:
1. Open an handful of tabs.
2. Take on of the firsts
3. Middle click or right click->open link in new tab
Actual Results:  
Opened tab is now at the very end of tab list, often invisible due to required scrolling.

Expected Results:  
Tab should spawn as "next tab" in order to improve navigation between opened tab. 

Logical relationship between opened tab from current tab and this current tab is strong enough to allow that.
The general bug is bug 161836, but Firefox will probably not be changed (bug 262459)
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 262459
You need to log in before you can comment on or make changes to this bug.