No option for open new tab on right/left of current tab

RESOLVED WONTFIX

Status

()

enhancement
RESOLVED WONTFIX
15 years ago
9 years ago

People

(Reporter: james-lists, Unassigned)

Tracking

unspecified
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 -
blocking-firefox3.5 -
blocking-firefox2 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [parity-ie][parity-chrome], )

Attachments

(1 attachment)

Reporter

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040923 Firefox/0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040923 Firefox/0.10

When I open a new page in a tab, say using the middle mouse button, the new tab
opens on the end of the existing tabs. This makes using tabs difficult as its
hard to remember which tab opened which. For me this is a major useability bug.

This should be configured as a setting within firefox and mozilla. The
multizilla add-on for mozilla gives me this, but it should be standard. 

Reproducible: Always
Steps to Reproduce:
1. Open three tabs
2. Select the first tab
3. Open a link in a new tab


Actual Results:  
New tab opens as the fourth tab

Expected Results:  
New tab opens as the second tab (with user option to select new tab on right of
current tab)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

15 years ago
*** Bug 279731 has been marked as a duplicate of this bug. ***

Comment 2

15 years ago
If this enhancement is implemented, and I click the "New Tab" button, this new
tab should NOT open next to the currently focused tab, because it would split up
tab relationships that are already in place.  Instead, it should still open as
the right most.  

A seperate enhancement request to allow one to move tabs around should be
created for the purpose of inserting a new tab within the current ones (and
moving tabs around).

Comment 3

15 years ago
Also, in single window mode, this enhancement should also refer to regular links
that normally open in a new window, Javascript popup links, and popups.

Comment 4

15 years ago
"If ... I click the "New Tab" button, this new
tab should NOT open next to the currently focused tab"

The opposite is true with me. The most likely reason for me to summon a new tab
is when i want to google for some extra info related to the info in an active
tab which i was reading. I'd say that for consistency sake the new tab should
always be inserted at a predictable position (be it from a link, new tab button,
bookmarks menu, history, or whatever).

"A seperate enhancement request to allow one to move tabs around should be
created for the purpose of inserting a new tab within the current ones (and
moving tabs around)."

Why can't you just activate the rightmost tab before hitting a "new tab" button?
I'd say activating a tab before adding a new one next to it is a bit simpler
than dragging things around. Anyway, there already is an RFE for tab dnd: bug
179656.

Comment 5

15 years ago
Ok, that is valid reasoning.  This means we have to come up with some ideas:

1.) Have a setting for new tabs created from links (right most, next right, next
left, left most) and separate setting for new tabs created by the new tab button
(right most, next right, next left, left most).  This is good, but actually, I
would sometimes like to insert a tab and sometimes add a tab to the end.  So...

2.) Have a setting for where new tabs are created relative to the current one. 
Then have two "new tab buttons" - One "insert tab button" and one "new tab
button".  The problem with this option is that it is confusing and two separate
buttons would be bloat and frankly, unnecessary.  So...

3.)  Like 1.), Have a setting for where new tabs from links are placed, and also
like 1.), have a separate setting for where new tabs from the new tab button are
placed.  Make a middle click on the new tab button perform the alternative
option to the one selected.  Seems very intuitive to me.  :) 

Comment 6

15 years ago
(In reply to comment #3)
> Also, in single window mode, this enhancement should also refer to regular links
> that normally open in a new window, Javascript popup links, and popups.

It probably isn't necessarly, but just to clarify comment #3:

In single window mode, make sure this enhancement is applied to all cases:
1.) to regular links that would normally open in a new window
2.) to Javascript links that would normally open in a new window 
(browser.link.open_newwindow.restriction behavior should NOT be altered)
3.) any popups
4.) any links opened with middle click
5.) any links opened with the context menu "Open link in new tab"
6.) when middle-clicking a folder of links, it should also respect this enhancement

Have I missed any cases?  Thanks

Comment 7

15 years ago
Single window mode should also trap shift+click (as well as ctrl+click).

Comment 8

15 years ago
And links/files opened from external applications.

Comment 9

14 years ago
You have tabs A, B, and C already open.
You open child tabs A1 and A2 from A into the background with a middle click.
Now the tab bar should read A, A1, A2, B, C, *NOT* A, A2, A1, B, C.

Stating that in words, Firefox should know that A1 is already the first child of
A, and so
open A2 to the right of A1.

You close A, and now are reading A1.  You open child tabs A1a and A1b from it
into the background with a middle click.  The tab bar should now read A1, A1a,
A1b, A2, B, C.

Comment 10

14 years ago
*** Bug 316265 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Depends on: 161836

Comment 11

13 years ago
*** Bug 344204 has been marked as a duplicate of this bug. ***

Comment 12

13 years ago
Moving the Firefox patch over from bug 161836:

This patch adds a new pref (browser.tabs.tabOpenLogic) which allows to control
where new tabs are added. It supports both schemes

[A 1 2 3 B C] and [A 3 2 1 B C]

(where the numbered tabs are added in the background from tab A) and allows to
specify whether blank tabs (which nicely includes tabs opened from external
applications) should be handled specially or not.

Should this be the way to go, we'll have to think the default behavior over (I
propose to open non-blank tabs in the IMHO expected order [A 1 2 3 B C], but I
don't really care as long as it's customizable).
Attachment #229269 - Flags: review?(mconnor)

Updated

13 years ago
Flags: blocking-firefox2?
OS: Linux → All
Hardware: PC → All
Target Milestone: --- → Firefox 2 beta2
Version: unspecified → 2.0 Branch
Comment on attachment 229269 [details] [diff] [review]
allow to customize this behavior

So, we're absolutely not adopting this change by default.  We've had this discussion a number of times, and we keep coming back to the case where in the A 1 2 3 B C case, opening 3 is not really that predictable.  The onselect behaviour here creates some extra weirdness and unpredictability.

I'd want to see a spec and a rationale behind the behaviour you're looking to implement before I review a patch for this.
Attachment #229269 - Flags: review?(mconnor) → review-
While this is useful in the overflow case, in theory, this is either another change in behaviour that its too late in the cycle to mess with, or its just a hidden pref, in which case we're not going to block on the implementation.

Worth discussing and testing on trunk at some point, but this isn't the right time to try to work out new heuristics.
Flags: blocking-firefox2? → blocking-firefox2-

Comment 15

13 years ago
(In reply to comment #14)
> While this is useful in the overflow case, in theory, this is either another
> change in behaviour that its too late in the cycle to mess with, or its just a
> hidden pref, in which case we're not going to block on the implementation.
> 
> Worth discussing and testing on trunk at some point, but this isn't the right
> time to try to work out new heuristics.
> 

I agree that we do not have the time to discuss and deploy new heuristics for Fx2, but can we do some basic implementation of allowing a user to choose to open a new tab next to the current tab instead of at the end of tab bar through an option in the preferences panel? 

A common use case would be a user working with >20 tabs (hence overflow). Lets say the current tab is Tab No. 2. Any new tab opened either through the address bar or through links in Tab No. 2 will open as Tab Nos. 21 and onwards (will require scroll or Menu Dropdown + Select); IMO not a great usability experience. I believe a user should have the option to open the new tabs right where he is at that point in time (i.e next to Tab No.2).

Please consider this basic scenario to be implemented for Fx2. Thanks.

Comment 16

13 years ago
Requesting to Block Fx 2. This request is ONLY for the feature to include a user preference to 'Open New Tabs next to Current' with NO CHANGES to Tab Heuristics.
Flags: blocking-firefox2- → blocking-firefox2?
Assignee: bugs → nobody
Discussed with beltzner, we've decided to just mark this WONTFIX, since we have no intention of adding support for this now or in the future.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Flags: blocking-firefox2? → blocking-firefox2-
Resolution: --- → WONTFIX

Comment 18

13 years ago
so it is completely over? how about once the 2.0 final is out?

Comment 19

13 years ago
*** Bug 358993 has been marked as a duplicate of this bug. ***

Comment 20

13 years ago
I couldn't find this bug before filing a dupe because I never imagined that it would be WONTFIX. I don't care where new tabs open because it gets focus, but the current interface is horrible for new tabs opened from existing tabs.

1. Open link in new tab.
2. Scroll all the way to the end to see the tab you just opened.
3. Scroll all the way back to go back to your previous tab.

I urge people to try the following extension to see how see first-hand how much easier it is to open links in new tabs. It doesn't do things exactly the way I like but putting aside the specific details of how to fix this, _something_ should be done about the current behavior.

https://addons.mozilla.org/firefox/1956/

In my opinion, this isn't an extension thing, it's bad handling of a common use case and should be accounted for. If the decision is to not fix, I would like to see some arguments on why fixing the current behavior is a bad idea. Firefox 3 has yet to reach alpha so I think the best time to fix this is now.

I don't mean to sound hostile, I just think the decision to never fix is... odd.

Comment 21

13 years ago
Comment on attachment 229269 [details] [diff] [review]
allow to customize this behavior

FYI: Some playing around with IE7 reveals that they've chosen to implement options 0 (Firefox' default) and 4 (open new non-blank tabs to the right [almost correct order]) of this patch -- and default to the latter. This might get us indirectly some interesting user feedback on this bug...
Duplicate of this bug: 366853

Comment 23

13 years ago
Ok, the rush to finalize Fx2.0 is over.  Now is the time to fix this bug.  (I hate to say this...) I like the way IE7 handles opening tabs spawned from other tabs.  When you open a link from within a tab the link opens in a tab immediately to the right of the current tab.  When you open a new blank tab, they open on the far right at the end of the tab bar.

Updated

12 years ago
Duplicate of this bug: 351652

Updated

12 years ago
Duplicate of this bug: 396335
Fwiw, IE7 users that might want to switch or are switching to Firefox might prefer IE7 behavior, because they are already used to it. So at least a pref that can be toggled in about:config is not superfluous, I would think.

Comment 27

12 years ago
I think it is time to reopen this bug.  There is already a patch, how about applying the patch to the development branch?  Just because Microsoft does something, does not mean that it is wrong.  I agree with Mr. Wargers.  IE7 has got tab opening correct.  
Don't see it as following, see it as the evolution of tabbed browsing.  Survival of the fittest.  Those who do not adapt, die out.

Updated

12 years ago
Duplicate of this bug: 403402

Comment 29

12 years ago
I think we should really re-consider this use case:

i. Since it really makes logical sense to do so
ii. As someone said above, its implemented in IE7 and users who switch will be used to it

Disclaimer: Not suggesting to implement this bug because its implemented in IE7, but because its actually the expected behavior.

For example, even if a user has just 15 tabs open and opens new tabs from links on the first tab, it will open in Tab #16. Its just not convenient to switch between 1 and 16... then come back to one, open another link... go to 17.

The ideal behavior should be [1][A][B][C][2][3] where A, B, C are child tabs of Tab #1 opened in that order.

I sincerely request the Firefox 3 drivers to consider implementing this... maybe as a part of the UI Delight plan for Fx3 (http://wiki.mozilla.org/User:Beltzner/UI_Hit_List).

Note: I don't see the option to set wanted-Firefox 3, hence setting blocking-Firefox 3.
Flags: blocking-firefox3?
take it to dev-apps-firefox, a wontfixed bug is not the place to make a compelling case.
Flags: blocking-firefox3?

Updated

12 years ago
Duplicate of this bug: 406995
Duplicate of this bug: 423058

Comment 33

11 years ago
11 bug reports created (10 marked as duplicates), and this one is still marked as "RESOLVED WONTFIX"... perhaps this should be re-opened? as it seems that most people on this thread agree that the current setup isn't perfect.

Personally I just want new tabs to always open one place to the right.

For example:

  A A2 A1 B C

Where the user focused tab A, then opened tab A1 followed by A2.

I see this as a standard stack behaviour, where the latest tab to be opened goes to the top of the stack... not only should this be easier to implement, but it is also the most consistent behaviour... going on the basis that users might get confused if tabs start opening all over the place.

Also, I would suggest that this works for both opening links, but also a blank new tab... on the basis that when I open a tab, its nearly always related to the current task I'm working on... i.e. to perform a Google search related to the content on the current page.

At the moment, every time I open a tab, I have to move it (if I want to keep them in some kind of order)... this suggest that there is a problem, where need to keep repeating an action that the browser can do for me automatically.
Flags: blocking-firefox3?
This doesn't block Firefox 3.
Flags: blocking-firefox3? → blocking-firefox3-

Comment 35

11 years ago
Ok, perhaps not blocking the release of Firefox 3, but can we at least remove the "RESOLVED WONTFIX" status... perhaps set it to "REOPENED"?

Updated

11 years ago
Duplicate of this bug: 429438

Updated

11 years ago
Duplicate of this bug: 432555

Updated

11 years ago
Duplicate of this bug: 433257

Comment 39

11 years ago
Show we open another bug with a voting to reopen this one? =)

Comment 40

11 years ago
Considering the number of duplicate bug reports issued (13), and the number of people who have commented on this (17), there has to be something to it... even if its just adding a hidden preference setting in "about:config".
We're not going to add poorly-tested codepaths.  Adding crap about:config isn't some sort of zero-cost solution.  We should figure out the right defaults, and leave infinite configuration to the extension developers to riff on.
There are various things where was decided to follow the behavior/looks of what the particular platfrom is doing.
It would make sense to do this here too, since IE7 basically makes this a platform specific behavior.
That is the default behaviour of other browsers, not only IE. I am a Maxthon long time user, it has an excellent tabbed-browsing implementation. Only today I consider to switch to Firefox because now I see a way to fix this and others tabs-related limitation by using an extension. Immediate usability is important to spread a software product. I strong support simply change the current behaviour, also without add a configuration parameter if this is a problem, because it's actually the expected behavior: similar pages close to similar pages... Please, open a new discussion in dev-apps-firefox mailing-list and this time take a different decision. :-)

Updated

11 years ago
Duplicate of this bug: 442884

Updated

11 years ago
Whiteboard: parity-ie
Target Milestone: Firefox 2 beta2 → ---
Version: 2.0 Branch → unspecified

Comment 45

11 years ago
In https://addons.mozilla.org/en-US/firefox/reviews/display/1956?show=100 it's said: 

When opening a new tab, nobody wants to be forced to scroll potentially dozens of tabs away from the current position/tab all the way to the very far right end of the line of open tabs. As a default behavior, that's just absurd and not just a little frustrating. This clearly should not be.

Tabs-open-relative functionality ranks right up there with "Tabs Close and Focus Relative"-type functionality. We want Relative! We need Relative! We don't want tabbed browsing to be completely disjointed and presented non-relatively. And if I'm suddenly forced past twenty tabs to the far right and everything I was just looking at has disappeared off to the left...

Wha...??

That's just wrong. I don't want to have to go back pawing through tabs and guessing where I was last. What if I didn't memorize the page title or whatever?

Updated

11 years ago
Duplicate of this bug: 453953

Updated

11 years ago
Duplicate of this bug: 453958

Comment 48

11 years ago
Can we please reopen this? or are we still convinced that this is not the expected behavior?

I agree with Connor #c41 that we should leave it to Extension Developers to extend the Browser's capabilities - but IMO we should not leave it to them to introduce the basic browsing functions - and this one is basic.
Flags: blocking-firefox3.1?

Comment 49

11 years ago
Please advocate for this in the mozilla.dev.apps.firefox newsgroup.
Note however comment #13 to comment #17.
Whiteboard: parity-ie → [parity-ie][parity-chrome]

Comment 50

11 years ago
Zeniko: Saw those comments (from pre-2.0 release). Isn't it surprising that 2 years ago, we would have been the first ones to do it. Today, it has become the expected behavior (on account of other browsers, who now have taken it one step ahead - IE8's tab grouping is a really good and simple thought), and we still don't have it.

Comment 51

11 years ago
> and we still don't have it.

Nowadays the situation is even worse, another player has it and we don't. Google has done its analysis (you know they care) and Chrome does not open the new tab at the total right end.
This bug is not about doing a smarter grouping, or changing our default open location as I understand it, but about inserting an option.
Flags: blocking-firefox3.1?
Flags: blocking-firefox3.1?
Flags: blocking-firefox3.1? → blocking-firefox3.1-
Flags: wanted-firefox3.1?

Updated

11 years ago
Duplicate of this bug: 464649

Comment 54

11 years ago
(In reply to comment #52)
> This bug is not about doing a smarter grouping, or changing our default open
> location as I understand it, but about inserting an option.

Mike: I agree, so in that case can we please reopen this bug and add an option to Tools -> Options -> Tabs where a user can select to open 'New Tabs' & 'Links from Current Page' next to the Current Tab. I hope you agree that the usability gains would be substantial.
Adding options is not something we should be doing lightly to Firefox. If we believe that the default behaviour should be that new tabs should open adjacent to the current tab, then let's change that default behaviour. My point in comment 52 is that the WONTFIX is about adding an option, not changing the default behaviour. I think there are reasonable arguments to re-evaluate our "always at the end of the tabstrip" behaviour in a world where more users are browsing with many tabs.

Right now that's being tracked in bug 161836, which is a Seamonkey bug, but we could do with a Firefox one, as well.

Comment 56

11 years ago
Beltzner: Based on your comment, have filed Bug #465673. Kindly confirm the same.
Thanks.
Depends on: 465673
Flags: wanted-firefox3.5?
Duplicate of this bug: 539986
Duplicate of this bug: 547174

Comment 59

9 years ago
Re: comment #55

(The Firefox version of Bug #161836 you mention is Bug #528005)

Whether it needs to be an option depends on whether the the new tab is opened to the _left_ of the current one, or to its right.  If the new tab is opened to the left of the current one, then that only changes the position of the new tabs, not their sequence, and that could be just a change in behavior, without needed a separate option.

However, if the new tab is opened to the right of the current tab, that changes both the position _and_ sequence of the tabs, which IMO does need to be an option, especially if the new behavior being proposed primarily helps "users [who] are browsing with many tabs" and hurts (newer) users browsing with fewer tabs, or users like myself, who have many tabs open, but work from left to right (opening pages that need to be viewed in tabs, closing them afterward), rather than right to left.

More detailed explanation:

Since the default behavior is to open tabs in forward (left to right) order, if the behavior is changed such that a new tab is opened to the right, and multiple new tabs are created in this manner, it will result in the new tabs being in _backwards_ sequence.

Opening links in a new tab _next_ to the current one works right only when the user opens a single tab at a time, closing it afterward before opening another tab in the same manner, or if the new tab is opened to the _left_ of the current tab.

For example, if the user has the following tabs opened already:

 Site A-Page 1, Site B-Page 1

and Page 1 of Site B has links to additional pages:

   Page 2
   Page 3
   Page 4

and the user opens those additional pages in new tabs in sequence (Page 2, Page 3, Page 4), those pages should appear in sequential tabs in ascending order:

 Site A-Page 1, Site B-Page 1, Site B-Page 2, Site B-Page 3, Site B-Page 4,
etc.

If every new tab is opened to the right of the current tab (Site B - Page 1), then the newly-opened tabs will be in the _wrong_ (backwards) order:

 Site A-Page 1, Site B-Page 1, Site B-Page 4, Site B-Page 3, Site B-Page 2

To correct this, the user would have to start at the bottommost link (Page 4) on the page and work their way back to the earlier links (Page 3, Page 2) when doing multiple "open in new tab" operations at once, or else drag the tabs around to reorder them before they could start reading the additional pages moving from left to right.

In summary, the reason it needs to be an option (if new tabs are added to the right of the current one rather than the left) is based on the fact that users who work differently will want it to work differently:

a) users who work with only a few tabs will be comfortable with the default behavior, opening tabs in forward sequence

b) users who open a single new tab at a time will want that tab to be next to the current tab

c) users who open multiple tabs at a time from a single page will want those tabs to be in forward sequence, thus working from left to right using the browser to keep track of which pages they have viewed so far

Thanks!

Comment 60

9 years ago
Agreed with previous commenter.  Why would you at least not have a preference for changing this option, particularly when it changes years of expected browser behavior?

Comment 61

9 years ago
I was going to open a bug about this.. and I saw there are multiple bugs already opened on this issue. 

The new feature is simply HORRIBLE. Imagine you have ~10 tabs opened. You open a link in a new tab... then what? You automatically click on the last tab. It's not it. So, you start searching through all your opened tabs to see where the hell is the new one. You'd say: it's right next to your active tab. Thanks a lot, you think I actually remember which of my 10+ tabs was the last active one?

Do you know how annoying this is? The more tabs you have opened, the harder it is to find the newly opened tab. Sometimes you're lucky and it's loading slowly, so you can spot it by the loading icon. But most of the times, the new tab loads quickly, and then it's hell finding it. Not to mention if you open several tabs.. it completely messes up any order/logic you had on the browser when opening up those tabs.

Please remove this feature or at least add a custom option to disable it.

Comment 62

9 years ago
Go Chrome and see if it works for you. This bug is WONTFIX.
Adding SUMO article as a reference.

You know, maybe it wouldn't be too hard for one of the many people who've filed dupes on this bug to write a Firefox extension to expose the pref...  It's certainly a better answer than "Go Chrome."

I could probably write the extension in under four hours.  But I won't, because I'm pretty busy and this is really more of an annoyance than a real loss of functionality.
You need to log in before you can comment on or make changes to this bug.