Closed Bug 403557 Opened 12 years ago Closed 12 years ago

Unable to add a new toolbar

Categories

(Firefox :: Toolbars and Customization, defect)

PowerPC
macOS
defect
Not set

Tracking

()

VERIFIED INCOMPLETE

People

(Reporter: marcia, Unassigned)

Details

Attachments

(1 obsolete file)

Seen using Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O 10.5; en-US; rv:1.9b1) Gecko/2007110903 Firefox/3.0b1. I was using Leopard on the PPC mac, I will have to check whether this happens on Tiger as well.

STR:
1. Context click on toolbar to expose customize toolbar menu.
2. Select Customize | Add New Toolbar
3. The dialog will come up behind the customize window (I think this bug is already on file).
4. Type a name for the toolbar and hit Enter. Then click done.
5. Go to View | Toolbars and to see if your new toolbar is in the list

Expected: My toolbar would be in the list and selectable.

Result: The toolbar is never in the list.  

This happens 100% of the time on PPC running Leopard. Running Leopard on Intel Mac, it happens intermittently - sometimes the toolbar will be added, sometimes it will not.

I tested briefly on Tiger, and also got mixed results - the toolbar was added in some instances, but not in others.
Before you click done, you can see the new toolbar you added with a check mark next to it, but after clicking done the toolbar no longer shows in the UI.
The part of that that's interesting to me is that you ever see it added: those steps should result in adding an empty toolbar, which has always failed to add it. I wouldn't be surprised if you see some variability in what happens with a build from before bug 401425 landed, but the only steps I would expect to work are

1. Customize, Add New
2. Type name, hit enter (in a post-401425 build)
3. Drag something into the new toolbar
4. Click done
Repros on Intel Mac also.  Editing title and attaching screenshot.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b1) Gecko/2007110903 Firefox/3.0b1

Summary: Unable to add a new toolbar on PPC Mac → Unable to add a new toolbar
Attached image Screenshot of bug 395334 (obsolete) —
Blocks: 403942
Comment on attachment 288874 [details]
Screenshot of bug 395334

As comment 0 says, that's not what this bug is about - that's bug 395334.
Attachment #288874 - Attachment description: Covered up Add new Toolbar screenshot → Screenshot of bug 395334
Attachment #288874 - Attachment is obsolete: true
No longer blocks: 403942
Marcia: just to be absolutely sure: your steps do _not_ involve dragging an item into the newly created toolbar, right? If not, then the part where you see the toolbar always disappearing is a duplicate of bug 258040 - deleting empty toolbars, even if you just created them, is expected behavior.

But, for the part where you were sometimes seeing empty toolbars not deleted (the "sometimes the toolbar will be added" on Intel), could you please retest now that bug 401425 is in, and nothing weird should be happening from double-handling the Enter in the naming dialog? And if you still see empty toolbars not deleted when you close the customize dialog, do you see anything in the error console when it happens, and is the empty toolbar itself visible, or just an entry in the menu?
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → INCOMPLETE
Pretty sure that Marcia was just trying to create an empty toolbar; if not, she can reopen and clarify.

Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.