Filter UI: Move destination menu should not allow server selection

VERIFIED DUPLICATE of bug 40357

Status

P3
normal
VERIFIED DUPLICATE of bug 40357
19 years ago
10 years ago

People

(Reporter: laurel, Assigned: alecf)

Tracking

Trunk
Future

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-])

(Reporter)

Description

19 years ago
Using may23 m16 commercial build

The destination selection dropdown pertaining to MoveToFolder action should not
allow user to select the account lever/server level of any mail account. Not a
valid destination.  It should only allow for selecting folders/subfolders (and
what about IMAP no select folders?).

1.  From mail window, launch Message Filters (Edit|Message Filters).
2.  Click the New button.
3.  In filter rules dialog, set Action to Move to Folder.  Pulldown the
corresponding destination menu and select a mail account/server level. 
    Note the selection sticks and sticks through OK.

Expected:  Should not allow selection at account/server level for MoveToFolder
destination.
(Reporter)

Updated

19 years ago
QA Contact: lchiang → laurel
(Assignee)

Comment 1

19 years ago
I don't expect to fix this for beta2, but it's an FCS must have
Status: NEW → ASSIGNED
Target Milestone: --- → M18

Comment 2

18 years ago
adding keyword b3mail
Keywords: b3mail

Comment 3

18 years ago
Adding nsbeta3 to b3mail bugs.
Keywords: nsbeta3

Comment 4

18 years ago
Removing b3mail keyword (these bugs have been promoted now.)
Keywords: b3mail

Updated

18 years ago
Whiteboard: [nsbeta3-]

Updated

18 years ago
Target Milestone: M18 → Future
(Reporter)

Comment 5

18 years ago
Marking duplicate of 40357, since alec's fix (now reopened) applied to both news
and servers/accout levels.  That bug got the proper/better PDT rating, too.

*** This bug has been marked as a duplicate of 40357 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

18 years ago
Marking verified as a duplicate.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.