Closed Bug 403670 Opened 12 years ago Closed 12 years ago

TB 2.0.0.9 Windows Installer Says it's Firefox

Categories

(Thunderbird :: Build Config, defect, P1)

x86
Windows Vista
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mscott, Assigned: nthomas)

References

Details

(Keywords: regression)

Attachments

(6 files)

I just downloaded:

http://www.mozilla.com/en-US/products/download.html?product=thunderbird-2.0.0.9&os=win&lang=en-US

Ran the installer on vista and the UAC prompt for the installer claims the product is Firefox not Thunderbird.

This usually happens when the installer package is signed with the wrong key IIRC.

Should this stop the 2.0.0.9 release? Nominating.
Flags: blocking1.8.1.9?
Attached image Screenshot
I see this too.
Is this a problem with these builds too ?
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2.0.0.9-candidates/rc1/

I think that problem occurs in the first signing.
Yes, I'm seeing it with RC1 as well.
The release (signed) build also shows "Firefox" when you mouseover the .exe.
http://img217.imageshack.us/my.php?image=picture3hn2.png

"Software Updater" screenshot; going from 2006->2009 on Vista, using Help | Check for Updates
http://img216.imageshack.us/my.php?image=picture4ap9.png

"Thunderbird Helper" screenshot; going from 2006->2009 on Vista

Looks like the initial UAC prompt from a fresh install and the mouse-over issues Al posts in comment 4 and comment 5 are the instances where "Firefox" is present; the upgrade path *seems* ok?
> This usually happens when the installer package is signed with the wrong key
> IIRC.
We only have one key, not sure what other key you are referring to. 

Its possible I passed the wrong arg when doing the manual signing (investigation continues), but I only know of one key for signing exe/installer like this. At least, we've used the same key for previous TB releases without a problem so far.

If you know of another key, can you give more details?
It's not key issue, it's a result of copying over checkouts/7z/stubs/tagfile/app.tag from Firefox 2.0.0.7 signing, and the signing code failing to update that to the Thunderbird equivalent. The results is Firefox strings being used to rebuild the Thunderbird installers.
There's a test installer uploaded to
  http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/experimental/test/

Could someone with Vista see if this fixes the issue. It's had the full set of signing done, and is the equivalent of what we'd ship. 

I'll do them all if this one is OK.
Thanks Juan, looks like the issue is fixed. 

I'll go ahead and generate a full set of locales, but not push them out to the mirrors until we do some more spot checks.
Flags: blocking1.8.1.9?
Assignee: nobody → nrthomas
Priority: -- → P1
Full set verified ok by QA, we're shipping them RSN.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Duplicate of this bug: 404027
We verified this before we shipped 2.0.0.9; marking it for the record.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.