Filter/Search UI: Date criteria don't work

VERIFIED FIXED in mozilla0.9.3

Status

P3
normal
VERIFIED FIXED
19 years ago
11 years ago

People

(Reporter: laurel, Assigned: sspitzer)

Tracking

Trunk
mozilla0.9.3

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(6 attachments)

(Reporter)

Description

19 years ago
Using may23 m16 commercial build

The filter rules date criteria value field is currently a plain text field. It
should have some kind of date control widget. 

The date value field should have these properties:
1.  default to current date
2.  should default to a date format, with separators for day,month and year.
3.  should allow user to type/edit value for day, month or year.
4.  should not allow incorrect date to be typed in, i.e. no number out of range
for its focused field and only numbers, no text.
5.  should have increase/decrease control such as up/down arrow widget
6.  increase decrease control should work on the day,month,year portions of the
date field separately based on what portion has cursor focus
7.  should increase or decrease only within valid range for the day, month or
year, i.e. days = 1-31 months = 1-12 years = valid (4digit?) year format
(Reporter)

Updated

19 years ago
QA Contact: lchiang → laurel

Comment 1

19 years ago
I need to check in the datepicker...argh
Status: NEW → ASSIGNED
Target Milestone: --- → M17

Comment 2

19 years ago
mass moving to M18 and adding nsbeta3 keyword
Keywords: nsbeta3
Target Milestone: M17 → M18
(Reporter)

Comment 3

19 years ago
QA Note: also applies for Search messages ui. Verify both when fixed.
Summary: Filter UI: Date needs proper date value field controls → Filter/Search UI: Date needs proper date value field controls
(Reporter)

Comment 4

19 years ago
When a date filter is migrated from 4.x, the date is not shown in the filter ui
at all.  I assume because we have no format to translate it to. 

Do we want to worry about putting something in the ui for beta2 or pre-beta3?

Comment 5

19 years ago
It's too much work for beta2, but definately for beta3.

Comment 6

19 years ago
Adding mail4 triage nomination keyword.
Keywords: mail4

Comment 7

19 years ago
A minimal fix would be to describe the required format in the affected dialogs. 
 If you want to get the datepicker into beta3, please come explain why that's 
easy and safe.

Comment 8

19 years ago
+ per mail triage for what Steve suggested above.
Whiteboard: [nsbeta3+]

Comment 9

19 years ago
Adding myself to cc: list.

Comment 10

19 years ago
second pass: - per mail triage
Whiteboard: [nsbeta3+] → [nsbeta3-][cut 8/28]

Comment 11

19 years ago
What's the required date format? I'll add this info to the online Help. Thanks.
(Reporter)

Updated

19 years ago
Keywords: relnote3, relnoteRTM
(Reporter)

Comment 12

19 years ago
Alec, what's the status of your tweak for (any) date format to work? Please
comment soon...
(Reporter)

Comment 13

19 years ago
Last I spoke to alec, the date field has still not been tweaked to accept any
format... He indicated the date criteria option may need to be removed from the
search/filter ui if no fix is implemented by RTM.

Let me know if we need a separate bug to track the removal of date as a
choice...

Comment 14

19 years ago
this weekend (i.e. within the last 24 hours or so) I did what I think is a 
working tweak. I have to play with it a bit more. I think we should leave it 
as-is for nsbeta3 and fix it for rtm, assuming my 4 line tweak really does make 
it start working.
(Reporter)

Comment 15

19 years ago
Once again we're getting very close to another (THE) deadline...

For the final release record, going from Alec's last comments about RTM:
Will we tweak so at least one date format works, forget about this and leave it
as is, or remove date from criteria listing?

Comment 16

19 years ago
Sorry for the extra mail. Removing mail4 keyword.
Keywords: mail4
It seems unclear to me whether this bug requires either of a "developer" or 
"user" release note for Netscape 6 RTM. If anyone feels it does, can they please 
draft one and then nominate with the relnote-user or relnote-devel strings in 
the Status Whiteboard.

Thanks :-)

Gerv
Keywords: relnote3

Comment 18

19 years ago
reassigning my filter bugs to gayatrib..
Assignee: alecf → gayatrib
Status: ASSIGNED → NEW
(Reporter)

Comment 19

19 years ago
*** Bug 59481 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 20

19 years ago
*** Bug 59481 has been marked as a duplicate of this bug. ***
Keywords: mozilla0.8

Comment 21

18 years ago
marking nsbeta1- and moving to future milestone.  I don't know when this will
get done.
Keywords: nsbeta1-
Target Milestone: M18 → Future

Updated

18 years ago
Keywords: mozilla0.8.1

Updated

18 years ago
Keywords: mozilla0.8
(Reporter)

Updated

18 years ago
Summary: Filter/Search UI: Date needs proper date value field controls → Filter/Search UI: Date needs proper date value controls (criteria doesn't work)
(Reporter)

Comment 22

18 years ago
*** Bug 81649 has been marked as a duplicate of this bug. ***
moving this back onto the radar.  0.9.2
Assignee: gayatrib → sspitzer
Target Milestone: Future → mozilla0.9.2

Comment 24

18 years ago
moving to 0.9.3
Keywords: nsbeta3
Whiteboard: [nsbeta3-][cut 8/28]
Target Milestone: mozilla0.9.2 → mozilla0.9.3

Updated

18 years ago
Keywords: nsCatFood
I'll attach a screen shot of the 4.x windows date picker.

Comment 27

18 years ago
Posted image icq date picker

Comment 28

18 years ago
Posted image w2k date picker

Comment 29

18 years ago
No timeless, we aren't gonna implement anything that advanced.

Comment 30

18 years ago
ICQ2000b's date picker can be seen when you create a reminder and want to pick 
a date. W2k's date picker can be seen when you search for files or folders by 
date between [click dropdown button].

The w2k picker is part of the system so other apps may use it too.  Clicking 
on the year in the w2k picker makes the year an editable spincontrol.  Clicking 
on the month gives a context menu of the twelve months.

A control like the w2k one would probably be a nice addition, and having the 
drop down button replace the nc4 spin button would be an overal win.
good news, I've got the search / date filters working again.

1) loading / saving date filters (including migrated 4.x filters) works
2) date based searches work
4) date based filters work

right now, my "date" picker is a xul text box that only works when you enter
"d/m/yyyy"

but I've added it as another card in the search value deck, so it can now be
replaced by a more advanced widget if someone has the interest and cycles to fix
it.

I'll attach a patch.
Status: NEW → ASSIGNED
I'm now going to see if I can get date terms to come up with the current date
(in the d/m/yyyy format).

this is useful, and it will help users have a clue what format to enter dates
in. (until we have a date picker.)

Comment 36

18 years ago
r=timeless
fixed.

I'll open a new bug on implementing a better date picker.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Summary: Filter/Search UI: Date needs proper date value controls (criteria doesn't work) → Filter/Search UI: Date criteria don't work
original bug spun off to bug #90289
(Reporter)

Comment 39

18 years ago
*** Bug 92825 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 40

18 years ago
Using aug10 commercial trunk build: linux rh6.2, mac OS 9.0, win98.
Date searching, filtering generally work OK for POP and IMAP using the basic fix
(no widget -- that's being implemented with bug 90289/bug 92174). 

Criteria is now basically working.  
Any problems with specific date searches/filters will be logged separately.
 
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.