Live Bookmark dropdown lists display over Dashboard Widgets

RESOLVED DUPLICATE of bug 438789

Status

()

RESOLVED DUPLICATE of bug 438789
11 years ago
6 years ago

People

(Reporter: rusgray, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9

If I click a Live Bookmark to bring down the dropdown list of articles/pages, then push F12 to activate Dashboard, the Live Bookmark dropdown list will display at full brightness over any Dashboard widgets behind that screen real estate, and the Dashboard in/out animation is also hidden by the dropdown list.

Reproducible: Always

Steps to Reproduce:
1. Click a Live Bookmark to view a list of articles
2. Push F12 to activate Dashboard
3. Observe results, and repeat as many times as you like, with any Live Bookmark on the hotbar.  It happens the same way every time.
Actual Results:  
The dropdown list displayed over/in front of the Dashboard widgets/animation

Expected Results:  
Displayed the dropdown Live Bookmark list beneath the Dashboard, and faded like the rest of the non-Dashboard items on-screen

Comment 1

10 years ago
Same problem happen with Bookmark Editing Dialog:

1. Click star button of already bookmarked page to show Bookmark Dialog
2. Push F12 to activate Dashboard
3. Bookmark Dialog will be shown over dashboard widgets

Comment 2

10 years ago
see also bug 433340 especially the first patch of Masayuki for the bug.
https://bugzilla.mozilla.org/show_bug.cgi?id=433340#c84
I think that we should rollup the popped up widgets when Dashboard is activated. Josh, can we handle such timing in nsChildView or something?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → joshmoz
Component: Bookmarks & History → Widget: Cocoa
Product: Firefox → Core
QA Contact: bookmarks → cocoa
Version: unspecified → Trunk

Updated

10 years ago
Assignee: joshmoz → nobody
419098 a dupe?

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 438789
You need to log in before you can comment on or make changes to this bug.