Newly added tags in tag list appears checked for all bookmarks

VERIFIED DUPLICATE of bug 407540

Status

()

Firefox
Bookmarks & History
VERIFIED DUPLICATE of bug 407540
10 years ago
8 years ago

People

(Reporter: Vidar S. Ramdal, Assigned: mano)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b1) Gecko/2007110903 Firefox/3.0b1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b1) Gecko/2007110903 Firefox/3.0b1

When adding a new tag to a bookmark, and displaying it in list view, it appears that all bookmarks are tagged with this tag.

Reproducible: Always

Steps to Reproduce:
1. Go to Bookmarks -> Organise bookmarks
2. Click on a bookmark ("bookmark #1"), then click in the Tags field
3. Enter a (previously unused) tag, e.g. "mac"
4. Click the Down arrow button to display the list of tags - notice that the newly added tag is checked
5. Click on another bookmark ("bookmark #2")


Actual Results:  
In the tags list of bookmark #2, the "mac" tag is checked, all though "mac" is not present in the Tags field

Expected Results:  
The "mac" tag should not be checked for bookmark #2
(Reporter)

Comment 1

10 years ago
Created attachment 289469 [details]
Screenshots demonstrating the bug
Component: Bookmarks → Places
QA Contact: bookmarks → places
Assignee: nobody → mano
Flags: blocking-firefox3?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P2
Target Milestone: --- → Firefox 3 M11
Same happens for latest builds on WinXP. It seems that the tag list isn't updated anymore. The boxes only show a checked tag but not the correct value. If you collapse and expand the tag list it will show the correct values. I will attach a screenshot which also shows the other way. A tag is defined but not checked.

This also has a side effect. If you click on tags inside the tag list currently set tags aren't noticed and added again. I'll attach a screenshot.
OS: Mac OS X → All
Hardware: Macintosh → All
Version: unspecified → Trunk
Created attachment 292872 [details]
Not synced tag list
Could this bug be depending on bug 394353?
Duplicate of bug 407540.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Flags: blocking-firefox3+
Resolution: --- → DUPLICATE
Duplicate of bug: 407540
Status: RESOLVED → VERIFIED
Priority: P2 → --
Target Milestone: Firefox 3 M11 → ---
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.