Listboxes (select multiple) don't get focus anymore

VERIFIED FIXED

Status

()

P2
major
VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: martijn.martijn, Assigned: hwaara)

Tracking

(4 keywords)

Trunk
access, dogfood, regression, testcase
Points:
---
Bug Flags:
blocking1.9 +
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Created attachment 289732 [details]
testcase

See testcase, the listbox should have a focus outline, but that doesn't happen anymore with current trunk build.
Also with clicking on it, you don't get a focus outline. It seems impossible to set focus on it.

This regressed between 2007-11-19 and 2007-11-20:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-11-19+04&maxdate=2007-11-20+06&cvsroot=%2Fcvsroot
Regression from bug 392040?

A smaller regression range could help blaming the right set of people here.
Flags: blocking1.9?
Works (focus outline around first element in listbox)
- 20071119_0956_firefox-3.0b2pre.en-US.win32

Broken (no focus outline around first element in listbox)
- 20071119_1127_firefox-3.0b2pre.en-US.win32

Checkins to module PhoenixTinderbox between 2007-11-19 09:56 and 2007-11-19 11:26 : http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1195494960&maxdate=1195500419

So due to bug 392040 or bug 393721.
(Reporter)

Comment 2

11 years ago
Thanks, I just have verified that backing out the fix for bug 392040 fixes this bug.
Blocks: 392040
Severity: normal → major

Updated

11 years ago
Keywords: access, dogfood
OS: Windows XP → All
Hardware: PC → All

Updated

11 years ago
Flags: blocking1.9? → blocking1.9+
Priority: -- → P2
(Assignee)

Comment 3

11 years ago
When the listbox is created, its view was shown before my patch, not it isn't. I guess the focus and key events don't reach the listbox because the view usually takes care of this, which is now hidden.

So the fix is to adjust my patch from bug 392040 to make sure listbox selects have their view visible after creation. I

I'll try to find some time to come up with a patch this weekend.
Assignee: nobody → hwaara
(Assignee)

Comment 4

11 years ago
Unfortunately my MacBook broke down this weekend, so I will not be able to get to this until the service repair has been done.
I hate to say "I told you so", but see bug 392040 comment 9.

I've backed out the patch for that bug, since this one is blocking both me and Gavin, at the very least, from reasonably using Bugzilla.  This is fixed.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Flags: in-testsuite?
Duplicate of this bug: 405435
(Assignee)

Updated

11 years ago
Flags: in-testsuite? → in-testsuite+
Verified FIXED using:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3pre) Gecko/2008012404 Minefield/3.0b3pre

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b3pre) Gecko/2008012404 Minefield/3.0b3pre

-and-

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b3pre) Gecko/2008012404 Minefield/3.0b3pre, using the testcase in comment 0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.