Closed Bug 405482 Opened 12 years ago Closed 12 years ago

'Restore Default Set' breaks Location Bar's drag and drop replace text and auto-submit feature

Categories

(Firefox :: Address Bar, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 3 beta2

People

(Reporter: I_am_RenegadeX, Assigned: dao)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007112605 Minefield/3.0b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007112605 Minefield/3.0b2pre

After going into 'Customize(Toolbar)' and clicking 'Restore Default Set', dragging and dropping URLs or text onto the Location Bar no longer replaces the existing text (also auto-submitting it in the case of a URL-link) as it does before doing this, rather it now just adds it to the existing Location Bar text, inserting it whereever the I-beam is when the mouse-click is released.

Reproducible: Always

Steps to Reproduce:
1. Confirm drag and drop of a URL-link or text from a webpage into the Location Bar works correctly (ie: replaces the current text, submits it in the case of a link)
2. If it works as expected, now right-click a toolbar and choose 'Customize'.
3. Click the 'Restore Default Set' button
4. Retest step#1



I discovered this while testing the latest Minefield(trunk) build and initially thought this was a recent regression on the Trunk only. However, I just tested it in Firefox 2.0.0.9 (20071025) and it is present there too so it may well have always been broken. I will test some old release builds and see if there was a regression window.
I can confirm that it was "broken" on Firefox 2.0.0.1, and even 1.5.0.7 (2006090918) so as nobody reported it since then, it was probably always broken but nobody noticed. The only reason I came across it was I was looking at Bug 403959 after running across a problem with the new implementation of the Minefield toolbar resizer.
ok, I'll take this
Assignee: nobody → dao
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is almost certainly because the dragdrop handlers get set in delayedStartup, not actually in the xul element:
http://lxr.mozilla.org/mozilla/source/browser/base/content/browser.js#1015
Attached patch patchSplinter Review
Attachment #290347 - Flags: review?(gavin.sharp)
Attachment #290347 - Flags: review?(gavin.sharp) → review+
Attachment #290347 - Flags: approval1.9?
Comment on attachment 290347 [details] [diff] [review]
patch

a=beltzner for drivers

(does this fix some other blockers about wonkiness after restoring the default toolbar set?)
Attachment #290347 - Flags: approval1.9? → approval1.9+
(In reply to comment #5)
> (does this fix some other blockers about wonkiness after restoring the default
> toolbar set?)

No, but if that means that such blockers actually exist, I'll have a look at them.
Checking in browser/base/content/browser.js;
/cvsroot/mozilla/browser/base/content/browser.js,v  <--  browser.js
new revision: 1.904; previous revision: 1.903
done
Checking in browser/base/content/urlbarBindings.xml;
/cvsroot/mozilla/browser/base/content/urlbarBindings.xml,v  <--  urlbarBindings.xml
new revision: 1.44; previous revision: 1.43
done
Status: NEW → RESOLVED
Closed: 12 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3 M10
Version: unspecified → Trunk
Component: Toolbars → Location Bar and Autocomplete
OS: Windows XP → All
Hardware: PC → All
Depends on: 410008
Duplicate of this bug: 401576
You need to log in before you can comment on or make changes to this bug.