Closed Bug 405645 Opened 14 years ago Closed 13 years ago

Search in bookmarks title for the autocomplete results

Categories

(Firefox :: Address Bar, enhancement, P1)

enhancement

Tracking

()

VERIFIED DUPLICATE of bug 278747
Firefox 3 beta3

People

(Reporter: sylvain.pasche, Unassigned)

References

Details

Right now, the autocomplete results is matching bookmark tags, document titles and document urls. However the result do not take the bookmark title into account.

This is not an issue when using the default bookmark title, because it is filled by the document title which will be matched in the autocomplete results. However, when changing the bookmark name (for instance, if the document has no title or a meaningless one), that would be great to see it appear in the autocomplete results.

Steps to reproduce:
1) open www.firefox.com
2) bookmark the page (<ctrl>-d), and set a name to "foobar"
3) type "foobar" in the address bar
expected:
I see the url matching that bookmark
actual result:
no match

This would be related to bug 399664. In this situation, the overridden bookmark title should be displayed instead if the document one.
Depends on: 378798
Requesting blocking; this seems like a big gap in the current implementation. I can currently search my bookmarks by title in the Bookmarks Sidebar and Places Organizer, why not in the location bar? (which would be much more convenient :)
Flags: blocking-firefox3?
I support both Sylvain's request and Andrew's note. In my opinion, this feature has been done right in Epiphany browser (http://www.gnome.org/projects/epiphany/), where typing part of the bookmark's title of tag suggests the list of available bookmarks.

I would like to note, that search by bookmark's label (tag) is already working.
Assignee: nobody → sspitzer
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P3
Target Milestone: --- → Firefox 3 M11
Priority: P3 → P1
Bug 278747 has recently been morphed (its new summary is 'Include bookmarks url's and titles in auto-complete url feature'); it has blocking flag and is targeted for M11; so to avoid confusion I think this bug should be duped to that one.
un-assigning seth's places/autocomplete bugs.
Assignee: moco → nobody
Status: NEW → RESOLVED
Closed: 13 years ago
Flags: blocking-firefox3+
Resolution: --- → DUPLICATE
Duplicate of bug: 278747
Verified dup
Status: RESOLVED → VERIFIED
Blocks: 378798
No longer depends on: 378798
You need to log in before you can comment on or make changes to this bug.