Linux system requirements need updating

RESOLVED FIXED

Status

defect
--
major
RESOLVED FIXED
12 years ago
7 years ago

People

(Reporter: bzbarsky, Assigned: reed)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [server side])

From my mail:


At the very least, we now require pango 1.10 or higher, built with cairo support (so that it provides pangocairo).  Which means we require a system cairo installed; not sure what the minimal version requirement there is.

I'm also pretty sure that we no longer work against XFree86-3.3.6 and haven't in years, but it's hard to tell because I don't think it's trivial to set up our other minimum requirements (e.g. xft) without a reasonably new X package. 

There might be other necessary updates too; I haven't kept up with things past installing a newer pango (and X a long while back), but the pango update pulled in glib and the like, which I'm not sure are strictly needed outside the RPM's little mind.
If someone can tell me what the new requirements should be listed as, I'm happy to make the change.

Here's the snippet of HTML with the current list:

  <h2>Linux</h2>
  <h6>Software Requirements</h6>
  Please note that Linux distributors may provide packages for your distribution which have different requirements.
  <ul>
    <li>Linux kernel - 2.2.14 or higher with the following libraries or packages:
      <ul>
        <li>glibc 2.3.2 or higher</li>
        <li>XFree86-3.3.6 or higher</li>
        <li>gtk+2.0 or higher</li>
        <li>fontconfig (also known as xft)</li>
        <li>libstdc++5</li>
      </ul>
    </li>
  </ul>
ccing some folks who might actually know.  I was sure I'd done that originally...
fontconfig and xft aren't the same thing for what its worth in the old stuff.

I suggest that we require pango 1.14 at least (1.16 would be better).
I believe we said pango 1.14, because that's what comes with RHEL5. http://wiki.mozilla.org/Linux/Runtime_Requirements

So the following items are the ones that people actually might not have in a distro such as RHEL4:

* Gnome 2.16 or higher
* Pango 1.14 or higher
* DBUS 1.0 or higher

We could enumerate a bunch of other requirements, but I can't think why we would:

* libstdc++ 6
* linux kernel 2.3.2 or higher (?)
* X11 version? do we require any extensions such as rendr?
Severity: normal → major
Duplicate of this bug: 427124
Flags: blocking-firefox3?
Flags: blocking-firefox3? → blocking-firefox3+
Whiteboard: [server side]
This would affect Thunderbird 3's system requirements because it will also be released on the same Gecko 1.9 platform, and as far as I know, identical system requirements were listed.
Also GTK+ 2.10 or later is required
Because I'm a jerk, I'm assigning this to mconnor. Please find someone who can tell us if this is right, and put the requirements in here and reassign to me and I'll happily make the change on mozilla.com
Assignee: nobody → mconnor
Duplicate of this bug: 438309
Is there a general bug for systems requirements updates needed for Firefox 3? I just checked ans this is not a linux only problem, we still list Windows98/ME as a minimum requirement for Firefox 3, there hasn't been any commits on SVN to update this page recently.

I need this page as soon as possible since we have to translate these requirements in 22 languages. Thanks.
(In reply to comment #10)
> Is there a general bug for systems requirements updates needed for Firefox 3? I
> just checked ans this is not a linux only problem, we still list Windows98/ME
> as a minimum requirement for Firefox 3, there hasn't been any commits on SVN to
> update this page recently.

Not sure what page you're looking at... https://www-firefox3.authstage.mozilla.com/en-US/firefox/system-requirements.html is updated for Mac and Windows (though CSS is broken).
Hi all, we Mozilla Japan are working to make the booklet called "about:mozilla", in which we write the goal of us, history of us, firefox/thunderbird product briefing, community introduction in Japan.

In the booklet we write the system requirement and deadline of the booklet is coming. We're very happy if this bug is solved soon, at least if requirements for linux kernel version is confirmed, we can write it.
(In reply to comment #4)
> * linux kernel 2.3.2 or higher (?)

If possible, confirm the linux kernel requirement at least soon please.
checked with caillon, the following appears to be correct

-----------------

Firefox will not run at all without the following system libs:

GTK+ 2.10 or higher
GLib 2.12 or higher
Pango 1.14 or higher
xorg 1.0 or higher

For optimal functionality, we recommend the following system libraries be installed:

NetworkManager 0.7 or higher
dbus 1.0 or higher
hal 0.5.8 or higher
GNOME 2.16 or higher
Over to reed for the mods; thanks connor!
Assignee: mconnor → reed
Still needs work, but this will do.

Sending        system-requirements.html
Transmitting file data .
Committed revision 15832.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
 <h6>Software Requirements</h6>
  Please note that Linux distributors may provide packages for your distribution which have different requirements.
  <ul>


the sentence is not in a <p></p>
Component: www.mozilla.org/firefox → www.mozilla.org
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.