Original UI isn't restored when closing Print Preview

RESOLVED DUPLICATE of bug 405683

Status

()

Core
Print Preview
--
major
RESOLVED DUPLICATE of bug 405683
10 years ago
10 years ago

People

(Reporter: mats, Unassigned)

Tracking

({dogfood, regression})

Trunk
x86
Linux
dogfood, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Original UI isn't restored when closing Print Preview.

STEPS TO REPRODUCE
1. load any URL
2. File->Print Preview
3. click on the Close button

ACTUAL RESULT
The only thing inside the window is the URL content -- the chrome menubar,
toolbar, status bar etc are gone.

I tried the patch in bug 396024 but it didn't help.

PLATFORMS AND BUILDS TESTED
Bug occurs in Firefox 2007112704 on Linux
Bug does not occur in Firefox 2007112604 on Linux
Flags: blocking1.9?
This seems to be worksforme, using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007112705 Minefield/3.0b2pre
(Reporter)

Comment 2

10 years ago
FWIW, after clicking "Close" I see the following error on the console:
JavaScript strict warning: chrome://browser/content/browser.js, line 6020: reference to undefined property this._cps
JavaScript error: chrome://browser/content/browser.js, line 6020: this._cps is undefined
(Reporter)

Comment 3

10 years ago
Hang on, the problem is related to this profile somehow...
(Reporter)

Comment 4

10 years ago
Created attachment 290484 [details]
content-prefs.sqlite

It's the "content-prefs.sqlite" file in my profile that causes the problem.
Odd, since it's mostly default settings AFAICT.
Just copying this file into an otherwise pristine (trunk) profile directory
causes to bug to appear.
(Reporter)

Comment 5

10 years ago
FWIW, the "_cps" errors in comment 2 seems to indicate pref service
usage in browser-textZoom.js somehow...

http://lxr.mozilla.org/seamonkey/search?string=this._cps
(Reporter)

Updated

10 years ago
Flags: blocking1.9?
(In reply to comment #2)
> FWIW, after clicking "Close" I see the following error on the console:
> JavaScript strict warning: chrome://browser/content/browser.js, line 6020:
> reference to undefined property this._cps
> JavaScript error: chrome://browser/content/browser.js, line 6020: this._cps is
> undefined

I saw this mentioned in bug 405483, comment 14, maybe related to this?

(Reporter)

Comment 7

10 years ago
Good catch, the patch in bug 405683 fixed it, thanks.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 405683
You need to log in before you can comment on or make changes to this bug.