Make the default packager format bzip2 instead of gzip for Camino 2.0

RESOLVED FIXED

Status

Camino Graveyard
General
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Simon Howes, Assigned: Mark Mentovai)

Tracking

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en; rv:1.9b2pre) Gecko/2007112700 Camino/2.0a1pre (like Firefox/3.0b2pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en; rv:1.9b2pre) Gecko/2007112700 Camino/2.0a1pre (like Firefox/3.0b2pre)

We could save bandwidth by changing the default compression used to package up Camino 2.0.  All users will be running 10.4+ so I see no reason not to.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

11 years ago
mento, any thoughts?
(Assignee)

Comment 2

11 years ago
It would be a pretty simple fix to pkg-dmg to make it treat UDBZ as it currently treats UDZO.  We'd also want some packager.mk magic to control the format.  Shouldn't be a big deal.  I'd support it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

11 years ago
Status: NEW → ASSIGNED
Assignee: nobody → mark
Status: ASSIGNED → NEW
(Assignee)

Comment 3

11 years ago
Created attachment 291469 [details] [diff] [review]
Support "--format UDBZ" in pkg-dmg

Karsten, this shouldn't conflict in any meaningful way with your patch.
Attachment #291469 - Flags: review?
(Assignee)

Updated

11 years ago
Attachment #291469 - Flags: review? → review?(mnyromyr)
(Assignee)

Comment 4

11 years ago
+     '-imagekey', ($format eq 'UDBZ' ? 'bzip2-level=9' : 'gzip-level=9'),

-imagekey bzip2-level=9 is only functional when writing disk images on Leopard.  On Tiger, the key is ignored, and 1 (smallest block size, least compression) is always used.

Comment 5

11 years ago
Comment on attachment 291469 [details] [diff] [review]
Support "--format UDBZ" in pkg-dmg

>-    if(command($gConfig{'cmd_hdiutil'}, 'convert', '-format', 'UDZO',
>-     '-imagekey', 'zlib-level=9', 
>+    if(command($gConfig{'cmd_hdiutil'}, 'convert', '-format', $format,
>+     '-imagekey', ($format eq 'UDBZ' ? 'bzip2-level=9' : 'gzip-level=9'),

FWIW, I don't run 10.5, just 10.4.11.
For me, gzip-level doesn't do anything, regardless whether its value is 1 or 9, so I suppose it's a typo: either  in the patch (you meant zlib-level?) or in your followup comment ("On Tiger, the key [bzip2-level] is ignored" actually talks about the gzip-level key)...

Some numbers for my SM debug builds (PPC):

UDZO zlib-level=9  => 19614664
UDZO gzib-level=9  => 23580698
UDZO zlib-level=1  => 23580698
UDZO gzib-level=1  => 23580698

I'm not sure if bzip2-level works for me, because the numbers differed only slightly, but changed in each additional run. :-/
This would of course support your comment #4...

UDBZ bzip2-level=9 => 17251970
UDBZ bzip2-level=1 => 17252035
(Assignee)

Comment 6

11 years ago
Created attachment 291903 [details] [diff] [review]
Support "--format UDBZ" in pkg-dmg, v2

You're right, good catch.  I've moved that back to zlib-level (typo!) and added a comment discussing bzip2-level.  ("file" handily tells you the bzip block size.)
Attachment #291469 - Attachment is obsolete: true
Attachment #291903 - Flags: review?(mnyromyr)
Attachment #291469 - Flags: review?(mnyromyr)

Updated

11 years ago
Attachment #291903 - Flags: review?(mnyromyr) → review+
(Assignee)

Updated

11 years ago
Attachment #291903 - Flags: approval1.9?
Comment on attachment 291903 [details] [diff] [review]
Support "--format UDBZ" in pkg-dmg, v2

a=endgame drivers.
Attachment #291903 - Flags: approval1.9? → approval1.9+
(Assignee)

Comment 8

11 years ago
Created attachment 292630 [details] [diff] [review]
Use --format UDBZ for Camino
(Assignee)

Comment 9

11 years ago
Checked in on the trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

11 years ago
Watching the cb-xserve01 tinderbox-builds, with no changes other than the default packager format switching from UDZO to UDBZ, Camino.dmg went from 14,913kB to 13,725kB.  -1,188kB 8%.
You need to log in before you can comment on or make changes to this bug.