Closed Bug 408233 Opened 14 years ago Closed 14 years ago

Downloading a trunk .dmg served as application/octet-stream using Safari results in .bz2 file

Categories

(Camino Graveyard :: General, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: alqahira, Unassigned)

References

()

Details

(Whiteboard: rdar://6032836)

mento wanted a placeholder bug for investigation of this, in preparation for filing in radar.

When a new bzip2-encoded trunk dmg is served as application/octet-stream and downloaded with Safari, it results in a .dmg.bz2 file, which BOMArchiveHelper or Archive Utility can't decompress (because, well, it's not a .bz2 file exactly, and they recompress it instead).

If the dmg is served with the non-standard (and non-default, except on our mirrors) application/x-apple-diskimage, all is well.  But the default Apache mapping is to application/octet-stream, which triggers this bug.

See also bug 318199 and http://bugs.webkit.org/show_bug.cgi?id=5883

Someone without FileVault should download jcraig's build (with Safari!) and verify my description/steps.
Using Safari in OSX 10.5.1 to d/l the December 13 trunk nightly from my .Mac
file sharing page, I can confirm that Safari is indeed appending the disk image
with a .bz2 extension, and using the default Archive Utility results in the
behavior described above.

I use The Unarchiver instead of Archive Utility (and BOMArchiveHelper before
that) and surprisingly (or maybe not), The Unarchiver IS able to successfully
decompress the .bz2 file, resulting in a .dmg file.
Is it a usable .dmg file?  bunzip2 can "decompress" .dmg files, but it won't include some trailing junk that's probably needed to mount the image.  At least I think so, I'm pretty sure I tested it.
On 10.4.11 ppc, using the latest webkit nightly and using Safari3:
* appends .bz2
* BOMArchiverHelper re-compresses that to a .cpgz file
* The Unarchiver turns the .bz2 into a .dmg, but it cannot be mounted (reason: not recognised in warning box)
Yes, I guess I should have been more thorough, like Phillipe's my .dmg can't be mounted: "not recognized".
mento, do you still want this open?
(In reply to comment #7)

> We should get this rdar://ed and then close it ;)
>

I thought it was already done…
Anyway: Bug ID# 6032836 filed with Apple

(and I had known the 'fix' for a while, maybe via the VirtualBox forums) 

Thanks, philippe.

Since this bug didn't affect us at all (that is, Camino code or Camino usage; it affected Safari users downloading jcraig's Camino builds) and was just a placeholder to make sure we filed what we discovered, INVALID.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → INVALID
Whiteboard: rdar://6032836
Also filed in WebKit's Bugzilla:
https://bugs.webkit.org/show_bug.cgi?id=19761
You need to log in before you can comment on or make changes to this bug.