Last Comment Bug 405762 - The 'yomigana' (phonetic) input fields in vcard editing window are emptied when users are trying to save that.
: The 'yomigana' (phonetic) input fields in vcard editing window are emptied wh...
Status: RESOLVED FIXED
: dataloss, intl
Product: Thunderbird
Classification: Client Software
Component: Address Book (show other bugs)
: unspecified
: All All
: P3 normal (vote)
: Thunderbird 3.0b3
Assigned To: Mark Banner (:standard8) (afk until 26th July)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-28 01:55 PST by Parag Nemade
Modified: 2009-03-04 02:56 PST (History)
5 users (show)
dmose: blocking‑thunderbird3+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Hide the phonetic fields as well for "vcards" (1.55 KB, patch)
2009-02-24 08:11 PST, Mark Banner (:standard8) (afk until 26th July)
mozilla: review+
neil: superreview+
Details | Diff | Splinter Review

Description Parag Nemade 2007-11-28 01:55:44 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b1) Gecko/2007110903
Build Identifier: 

The 'yomigana' input fields in vcard editing window are emptied when users are
trying to save that.


Reproducible: Always

Steps to Reproduce:
0. Ensures Japanese support and thunderbird are installed.
1. Open virtual terminal in gnome: Alt-F2 > `gnome-terminal` > Enter.
2. Start thunderbird in locale Japanese: `LANG=ja_JP.UTF-8 thunderbird`.
3. Open vCard editing window: '編集' > 'アカウント設定' > (select an account, or
create a new one) > (click on account name) > 'vCardを編集'.
4. Input some English typing into two 'よみがな' input fields > 'OK'.
5. Reopen vCard editing window: 'vCardを編集'.

Actual Results:  
Data in 'yomigana' (よみがな) should be updated.

Expected Results:  
'yomigana' (よみがな) fields are empty.

Reproducible on Fedora 8 with thunderbird-2.0.0.6-6.fc8 rpm installed.
Comment 1 Magnus Melin 2007-11-28 08:58:06 PST
I can input よみがな just fine using the latest english linux trunk build.
Comment 2 Mark Banner (:standard8) (afk until 26th July) 2007-11-28 09:59:35 PST
(In reply to comment #1)
> I can input よみがな just fine using the latest english linux trunk build.
> 

I've started having a look at this. 'yomigana' stands for phonetic. The phonetic address book fields can be enabled (in any language/locale) by setting the pref 'mail.addr_book.show_phonetic_fields'.

The problem is not in the address book, but in the account settings when you go to Account Settings for a specific account and "Edit Card" (next to attach my vcard to messages). Its there the phonetic fields don't get saved.

The problem is there we are saving the card as a vcard in prefs (not in an address book). I took a brief look at the code and the code doesn't save phonetic fields for vcards at the moment.

I still need to find out what the vcard spec says.
Comment 3 Caius Chance 2007-11-28 19:31:02 PST
(In reply to comment #1)
> I can input よみがな just fine using the latest english linux trunk build.
> 

Do you mean inputting a string in those two よみがな fields and click on 'OK'?
Comment 4 Magnus Melin 2007-11-29 08:06:36 PST
My test was for name, display name. Didn't know about phonetic fields "yomigana"... so please just disregard comment 1.
Comment 5 Caius Chance 2007-11-29 15:17:21 PST
Hi Magnus, for Fedora go to gnome-terminal:

$ LANG=ja_JP.UTF-8 thunderbird

should be able to get you there. - Rgds, Caius.
Comment 6 Mark Banner (:standard8) (afk until 26th July) 2008-05-01 07:09:55 PDT
The RFC (http://tools.ietf.org/html/rfc2426) for vcards, doesn't seem to support phonetic fields (or multiple names).

Maybe we should hide these fields from the vcard display?
Comment 7 Caius Chance 2008-05-01 16:35:40 PDT
Thanks Mark, I have two thoughts in my head:

- Is rfc2426 the latest and the most compatible specification available?
- Has this feature (fields) not been supported by other email client (e.g. OE, Euroda, etc) also?

Hope these questions help in clarification. Rgds Caius.
Comment 8 Dan Mosedale (:dmose) 2008-05-01 17:56:07 PDT
RFC 2426 is the latest actual spec (it's vCard 3.0).  Section 3.1.2 seems to suggest support for multiple names, but I just skimmed it, so I may have read it wrong.  

Additionally, there's an IETF working group working on updating that spec, so there may be newer drafts.  It would be interesting to know if they exist and say anything that would address this issue differently than 2426.

Support in other clients is a relevant question, as is support in Tb2.  I know that Tb 2 doesn't support all vCard 3.0 features, but I'm not sure if we support just vCard 2.0 or some superset of that.
Comment 9 Caius Chance 2008-05-01 21:20:35 PDT
Hi, if it had been confirmed that the field is not usable currently, IMHO we could hide it until all the supporting codes at the background are done. Rgds.
Comment 10 Dan Mosedale (:dmose) 2009-02-16 10:43:55 PST
Confirming, as per comment 6.  Since this is dataloss bug, adding that keyword, and since there appears to be a trivial way to avoid that dataloss (hide the field and don't accept the data at all), I think this should block Thunderbird 3.  Marking as such and giving to Mark.
Comment 11 Mark Banner (:standard8) (afk until 26th July) 2009-02-24 06:47:14 PST
I've done some research, and I can't see any room for phonetic fields in the vcard standard at the moment. We'd certainly need to update our vcard support anyway. So I think it is best to disable those fields.
Comment 12 Mark Banner (:standard8) (afk until 26th July) 2009-02-24 08:11:36 PST
Created attachment 363882 [details] [diff] [review]
Hide the phonetic fields as well for "vcards"

This hides the phonetic fields as well when we bring up the vcard for editing in the account manager (to test set mail.addr_book.show_phonetic_fields to "true").
Comment 13 David :Bienvenu 2009-02-25 07:52:36 PST
Comment on attachment 363882 [details] [diff] [review]
Hide the phonetic fields as well for "vcards"

won't this cause a redeclaration of "var i" warning with js warnings turned on? r=me, with that addressed.
Comment 14 Mark Banner (:standard8) (afk until 26th July) 2009-02-25 12:44:23 PST
Checked in with David's comment fixed: http://hg.mozilla.org/comm-central/rev/c066ee5931e3
Comment 15 Philip Chee 2009-03-04 02:56:54 PST
Use |for (let i ...)| to limit the scope of the "i" variable to the for loop. This way you can safely reuse "i" in different block scopes.

Note You need to log in before you can comment on or make changes to this bug.