Last Comment Bug 406254 - because we bold the selected text, the text shifts to the right (slightly) as you continue to match
: because we bold the selected text, the text shifts to the right (slightly) as...
Status: RESOLVED FIXED
[polish-easy][polish-visual][polish-p...
: polish
Product: Firefox
Classification: Client Software
Component: Location Bar (show other bugs)
: Trunk
: All All
: P3 normal with 1 vote (vote)
: Firefox 16
Assigned To: Nobody; OK to take it and work on it
:
: Marco Bonardo [::mak]
Mentors:
Depends on: 587909
Blocks: 393508 405745
  Show dependency treegraph
 
Reported: 2007-11-30 16:01 PST by (not reading, please use seth@sspitzer.org instead)
Modified: 2012-07-24 16:06 PDT (History)
22 users (show)
dietrich: blocking‑firefox3.5-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Possible formatting changes (98.56 KB, image/png)
2008-10-16 12:39 PDT, Alex Faaborg [:faaborg] (Firefox UX)
no flags Details

Description (not reading, please use seth@sspitzer.org instead) 2007-11-30 16:01:25 PST
because we bold the selected text, the text shifts to the right (slightly) as you continue to match.

sayre pointed this one out.

one suggestion he had was using black for the matching text and grey for the non-matching text.  (and dark green vs not-as-dark green for the matching url)
Comment 1 (not reading, please use seth@sspitzer.org instead) 2007-12-11 14:01:58 PST
using bold appears to have other issues, see bug #407861 "Bolding the found text in autocomplete breaks ligatures "
Comment 2 Simon Bünzli 2007-12-28 10:46:24 PST
(In reply to comment #0)
> one suggestion he had was using black for the matching text and grey for the
> non-matching text.

That'll lead to a variation of bug 409974, though. What about using HighlightText/Highlight instead? Won't look great, but it won't look out of place, either.
Comment 3 Ed Lee :Mardak 2008-03-20 14:51:29 PDT
*** Bug 424192 has been marked as a duplicate of this bug. ***
Comment 4 scratch 2008-04-10 13:14:04 PDT
how about using -moz-opacity: .8 or so on unmatched text?
Comment 5 Henrik Skupin (:whimboo) 2008-07-23 09:40:38 PDT
(In reply to comment #4)
> how about using -moz-opacity: .8 or so on unmatched text?

Alex, would that be a possible way?

Comment 6 Dietrich Ayala (:dietrich) 2008-10-15 21:41:34 PDT
Not going to block the 3.1 release for this. Alex Faaborg has recently talked about using contrasting colors instead of bold+underline to resolve this issue.
Comment 7 Henrik Skupin (:whimboo) 2008-10-15 23:33:18 PDT
(In reply to comment #6)
> Not going to block the 3.1 release for this. Alex Faaborg has recently talked
> about using contrasting colors instead of bold+underline to resolve this issue.

Dietrich, could you please set the flags accordingly?
Comment 8 Tony Mechelynck [:tonymec] 2008-10-16 11:55:24 PDT
(In reply to comment #6)
> Not going to block the 3.1 release for this. Alex Faaborg has recently talked
> about using contrasting colors instead of bold+underline to resolve this issue.

Of course, "contrasting" colors, when foreground-only (i.e., red vs. blue but not white-on-black vs. black-on-white) can be a problem for color-blind users. Maybe the underline should be kept.
Comment 9 Alex Faaborg [:faaborg] (Firefox UX) 2008-10-16 12:39:26 PDT
Created attachment 343431 [details]
Possible formatting changes

Here is a mockup of possible formatting changes.  This doesn't address the text shifting problem, since we are still using bold, but does clean up the appearance a little by removing the underlines and using contrast for emphasis.
Comment 10 Alex Faaborg [:faaborg] (Firefox UX) 2009-06-23 01:25:33 PDT
This bug's priority relative to the set of other polish bugs is:
P1 - Polish issue that appears in the main window, or is something that the user may encounter several times a day.

This effects every interaction with the awesome bar, so definitely something that users will encounter several times a day.
Comment 11 Andrew Hurle [:ahurle] 2012-07-24 16:03:09 PDT
This is fixed by bug 587909, which removes the bold.  Varying opacity may happen in bug 774118.

Note You need to log in before you can comment on or make changes to this bug.