Firefox won't start after update to 2.0.0.11

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: cyberhed, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461; SV1; .NET CLR 1.1.4322)
Build Identifier: Firefox 2.0.0.11

Error message states:

firefox.exe - Bad Image

The application or DLL C:\Program Files\Mozilla Firefox\nss3.dll is not a valid Windows image. Please check this against your installation diskette.

Reproducible: Always

Steps to Reproduce:
1.Try to open Firefox
2.
3.
Actual Results:  
Nuthin' doin', chief.

Expected Results:  
Firefox opens.  Life is complete.

Downloaded update file from Firefox.com will not open (shows file corrupt).

Comment 2

11 years ago
perhaps mark as duplicate of bug 406274
works for me with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/2007112718 Firefox/2.0.0.11

milan, can you try with a new profile (http://kb.mozillazine.org/Profile_Manager) and maybe with a installation in a different firefox directory (as exam xple c:\program files\firefoxtest 

do you have any extensions installed, did you update from Firefox 2.0.0.10 ?

Josh, if you get a similar error message, please attach this to this bug, since this bug has a little more info (error message), can you also please try the steps from above

Updated

11 years ago
Duplicate of this bug: 406274

Comment 5

11 years ago
i get no error message. simply doesnt start. tried complete uninstall, cleaned registry of all mozilla keys, reinstalled. still no go. must be some files firefox is leaving behind that are messed up.

Comment 6

11 years ago
update: found application data left behind and moved so firefox couldnt see it. reinstalled. now firefox says that it is already running. which isnt true. there is no firefox process in the task manager. even restarting my compy have the same error.
after replacing the app data. firefox loads into task manager but never appears
Josh, if you don't remove the profile entirely the part left behind can cause the message that firefox is still running.
Did you reinstall Firefox in an EMPTY folder? Just delete the folder in Program Files manually before reinstalling Firefox.


Comment 8

11 years ago
Unfortunately, I just logged a similar bug 406315.  Firefox loads for a short while, but once I start navigating a wesite it crashes.  I just tried your recommendation of manually deleting the directory.  Now I can't even load it.  It creates an error report. I can send it if it will help.
(Reporter)

Comment 9

11 years ago
Tried to create a new profile, but upon trying to run Firefox from the command line, got the same 'Bad Image' error message.  Was upgraded from 2.0.0.10 with a couple of add-ons (ForecastFox and Adstop).

Will try to reinstall in a new directory, but will have to download a new .exe as the one I have comes up as corrupt.

Will update.
(Reporter)

Comment 10

11 years ago
Update: downloaded new firefox.exe, ran, and installed fine.  Firefox works again!  Same installation location as before.  Perhaps the previous update file was corrupt?  Are there different versions of the file?  

Anyway, it is resolved for me.  You other may want to try downloading and installing again now.

Comment 11

11 years ago
ok directory fully removed, profile fulle removed. working now. sucks that it got screwed up tho.. gotta reset all my settings :\

Comment 12

11 years ago
fully*

since the both authors of these bugs have been satisfied, you can mark as resolved. ryan has his own bug and is being helped so hes good too...

Comment 13

11 years ago
I have also tried to put 2.0.0.11 on my wife's machine and it failed to start after the install.  I checked with Mcafee and made sure that the firewall was not blocking it and it was OK.  I removed foxfire and tried a new install and same thing.  So I then tried my machine that has never had foxfire and the same problem it installed but will not start.  When I try to start it I get a windows error message Bug 406288 FireFox won't start after update.  I never had it installed so why does it mention an update.  This is serious and will be causing a great many people some serious problems.  On my wife's machine I did a restore to last Thursday and FireFox ran once then it crashed and refused to run again.
WFMing per comment 12
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.